Vauxhall Owners Network Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Evening all

I'd very much appreciate some guidance on how to get the heater working in my 2011 Zafira Elite with climate control. Just spent a small fortune having the air con fixed only to discover that I'm not getting any hot air out of it!

Changed the thermostat today (as was wondering if it could have been responsible) and wanted to check / flush the matrix too but was unable to remove the hoses from the matrix stubs. One source online said to pull the collar back then remove the hose, the Haynes book of lies said to push the collar forward and remove. Needless to say I tried each and every way of doing it (hampered by the sodding fuel filter or something) but to no avail. Interestingly the top hose from the matrix got hotter before the bottom one. I would have thought the bottom one was the flow in and the top the return... Anyway, as both got hot I'm assuming there's is flow through the matrix unless they were purely heated by convection....

Can't seem to find an inline heater valve anywhere. Does anyone know if this model of Zafira has one? If so, and if it's electronically driven, it may have crapped up and / or knackered the servo that drives it. When the climate control temperature is altered, there is a whirring sound from somewhere, so a servo is responding but whether it's actually doing anything remains to be seen!

Welcome all input on this as need to get it sorted before the imminent chilly season starts.

Thanks very much

Graham
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #4 ·
Thanks very much. That's a very useful diagram. Can't see a mechanical valve on the hot water pipes though so maybe they don't have one on these models.
 

·
Registered
Joined
·
151 Posts
Are you local to south yorkshire? Could potentially scan it for you see if there any fault codes stored
 
1 - 12 of 12 Posts
Top