Vauxhall Owners Network Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi....I own a Zafira B 2013, which recently went in for the recall. Shortly afterwards the heater/blower started playing up - the heater will only work now between 2-3....won't go any higher or lower and won't turn off. The windscreen fan comes on at 7.....can be turned down to 6 but won't go any lower. Vauxhall had the car back to look at the heating system....told me I need a whole new heater control panel at £760 plus labour. Cannot fathom how everything can be okay one minute and then need that amount of work the next.

Any ideas/suggestions greatly appreciated. I am capable of doing small jobs myself....changed the ignition coil etc.
 

·
Premium Member
Joined
·
761 Posts
I havent had the time to take mine in for the recall so i checked it out myself. Mine stopped working altogether. I replaced the blower and regulator/ resistor.

It is easy to check yourself incase vauxhall missed something obvious. Remove your glovebox and youll see your blower motor. Make sure each of the wiring connectors are fully inserted. That would seem the most logical step to take next to me.

I changed the regulator/ resistor on mine and it worked until the next morning when it was back to square one. No blower. I removed the blower motor cleaned the worn brushes put it back and it worked. Until the next morning when no blow again !
I replaced the motor with a nearly new 2nd hand one and its worked fine ever since.
Im sure yours is the classic symptom of regulator/resistor failure.

If you do decide to remove the resistor please disconnect the battery first as its permanent live
There are youtube videos on this .

Good luck i hope its just the wiring not connected properly and not the heater control panel. I would be looking at a 2nd one before paying that price !

Bill
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Thanks for your reply awol.....much appreciated. I think you are right....having done some research around the internet it seems to be a common problem with the Zafira. As you suggested, I will try the wires and the resistor first....at £16.20 for a resistor it's somewhat cheaper than £760! Thanks for your help.
 

·
Premium Member
Joined
·
761 Posts
Before you order one check the part number because the ones fitted to electronic climate control models is different to the one fitted to manual models . Ours is described as a "headgehog" one youll see why if you google it.
Bill
 

·
Premium Member
Joined
·
761 Posts
I got one from Autovaux which seems to be a genuine part and a lot cheaper than a main dealer but who knows. Felt solid and it looked like a quality item.

Do you know for sure what parts the dealer replaced on yours? I read they changed the resistor and blower motor and maybe the pollen filter.

Bill
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
Hey.....no, they told me that they don't change or go near any of those parts when they do the recall....that's why they would not put it right for me. On the work sheet it says "advise customer that the heater control panel does not get removed during the recall and work is not carried out under warranty." I have read on some other threads though that some people have had the same problems after the recall and have got theirs repaired without charge....not sure how they worked that but I don't have any hopes of getting it done. Their own engineer told me to try the less expensive things rather than paying out £760 if it can be done for under £20.

I will check the part number as you suggested....I did read somewhere about the hedgehog thing....thanks for that.
 

·
Premium Member
Joined
·
761 Posts
Right if they havent replaced anything then i would do as i did. Remove the glovebox. Remove the actuating arm from the domed cover on the top of the blower fan. This allows you to look at the fan. See if it spins freely. I thought mine was okay initially but compared with the newer replacement it was a bit stiff. If it doesnt rotate freely you can either replace it with a new or 2nd part . You can of course clean it up i didnt have time to do this but its relatively easy to do.

The fact that yours works on some speeds suggests its the resistor thats gone though. (Mine wouldnt work on any setting.)but check the fan first because i think that has a bearing on the resistor failing in the first place.
Part number for the hedgehog type resistor is 90512510

I will get you the blower motor part number in the morning when im not alcoholically challenged.

Bill
 

·
Premium Member
Joined
·
761 Posts
Blower motor housing is a BEHR D9376
The replacement i put in was a BEHR
D9376006 which was out of a vauxhall model although i took a gamble on buying it . It and the actual motor turned out to be identical. If you need one and you go down the 2nd hand route look at photos of them and compare the date on the sticker as this is a guide to how old the replacement is.
Good luck

Bill
 

·
Registered
Joined
·
5 Posts
Discussion Starter #11
Thanks Bill....really appreciate your help on this. I will take a look as suggested before I buy any parts and then hopefully get it sorted without too much cost.
 
1 - 11 of 11 Posts
Top