Vauxhall Owners Network Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hi all .
I have a problem with my zafita automatic.
For starters it seems lazy going into first gear, you put It in drive and it takes 5 seconds before it engages.
Second problem.
After driving for about 2 hours and then slowing down the box goes into d3 but won't go into anything else unless you stop put it in park and turn engine off.
Then when restarted no probs d1 again.
I done a computer check codes p0700 and p0733 are present!
Gear ratio incorrect and malfunction indicator request from transmission module.
Any help please what this is and to rectify it.
Thank you
 

·
Super Moderator
Joined
·
27,026 Posts
Have you tried changing the transmission fluid ?
 
  • Like
Reactions: andy_v

·
Registered
Joined
·
116 Posts
I had issues with mine a long time ago I had a vectra 1.9 cdti 150 remapped to something stupid it was crazy quick. Now sometimes when giving it some beans it would go to change into third rev up then bang into third. Now I did an oil change and it seemed to rectify it for a while but after a month or so did it again. I put it down to the box couldn’t keep up with the speed it was shooting off at because it really was quick. However you can’t always get all the dirty oil out the box because the torque converter holds the majority of the oil.


Sent from my iPhone using Tapatalk
 

·
AstraG, AstraH, Astra conv.turbo, Corsa D, XKR
Joined
·
319 Posts
Drain and replace transmission fluid. It is supposed to be done at 40K according to Haynes manuals and Comma oil. Or take it to an auto trans specialist who will use a special machine to get all of the old fluid out before adding new. As advised above you cannot empty the complete system just be removing the drain plug.
 
1 - 5 of 5 Posts
Top