Vauxhall Owners Network Forum banner

1 - 8 of 8 Posts

·
Premium Member
Joined
·
9,979 Posts
Discussion Starter #1
Waiting for my Aux belt pulleys to arrive after waiting over a week (I can get things quicker from China than in my own home country), chirping got a little louder so wasn't using the car as much, low and behold today had to take Mother and Sister shopping everything OK, we called at my Aunties Mother not seen her for a few weeks, noticed when pulled on to Aunties drive there was a strange smell, but thought it was already in the air as she lives near some woods and farm land.

So on the way home about hour of so later noticed temp gauge started to rise slowly, put the heater blower on and there was no heat, got about 100 metres from home and there was a slight squeak and a puff of smoke come from under the bonnet, but the engine was still running fine and the temp just below 90, parked up and lifted bonnet and it stunk of burning rubber.

Outcome it looks like my water pump has seized.

Neighbour came out and offered to give me hand to do it at the weekend so I guess the car is off the road.

I've watched a few youtube videos and a tutorial from a different forum, only one video mentioned a cam locking kit, that was on a Signam 1.9cdti 150bhp which is the same engine in my Vectra.
 

·
Well-known member
Joined
·
11,998 Posts
Probably cos you have the same thing being discussed across a few other threads.
 

·
Premium Member
Joined
·
9,979 Posts
Discussion Starter #6
Probably cos you have the same thing being discussed across a few other threads.
I put this one up days before I asked the question in the Cavalier section, its just the point of 87 views and not one of them could reply, which makes you think how many members are there on here that never reply they just lurk.
 

·
Well-known member
Joined
·
11,998 Posts
I've given you a like to cheer you up.
 
1 - 8 of 8 Posts
Top