Vauxhall Owners Network Forum banner

1 - 20 of 39 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter · #1 ·
Hi so I normally get the misfire code I have a new Delphi coil pack on the way but Why did I get code u2139. P0650. I know what they mean but why did they randomly come up ? Hopefully someone can help :)
99117
 

·
Super Moderator
Joined
·
17,010 Posts
how many threads do you want on with the same car and same fault

 

·
Registered
Joined
·
64 Posts
Discussion Starter · #3 ·
how many threads do you want on with the same car and same fault

it’s not the same fault if would would of read it properly you would of seen I said not the misfire codes as I have already bought a coil pack I’m talking about the ecu codes
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #4 ·
how many threads do you want on with the same car and same fault

So who’s a doughnut Andy is :) 🤣🤣
 

·
Registered
Joined
·
364 Posts
Insulting people who try to help is not a very wise move.

U2139 - I would skip it for the time being. Some cars have it for years and everythig works.
P0650 - have you checked obvious things like indicator bulbs?
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #6 ·
Insulting people who try to help is not a very wise move.

U2139 - I would skip it for the time being. Some cars have it for years and everythig works.
P0650 - have you checked obvious things like indicator bulbs?
Wasn’t insulting him he’s just saying I posted the same thing when I clearly stated to ignore the misfire codes so he’s a doughnut he obviously didn’t read it and just looked at the picture

But yes mate all indicators are working fine so I’m not sure why that code came up ? So just ignore the steering column code for now
 

·
Registered
Joined
·
364 Posts
Actually, after reading again your first post, I have to retract my posts in this subject. It is showing problem with MIL indicator, which is quite interesting. It has nothing to do with the indicators or the uec. This is the led that is set ON when there is something wrong with the car. Any malfunction with it and the car fails the MOT.
My bet is you have a problem with wiring or connectors that goes between the ecu and the dials - this led is controlled by the ecu.
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #10 ·
Actually, after reading again your first post, I have to retract my posts in this subject. It is showing problem with MIL indicator, which is quite interesting. It has nothing to do with the indicators or the uec. This is the led that is set ON when there is something wrong with the car. Any malfunction with it and the car fails the MOT.
My bet is you have a problem with wiring or connectors that goes between the ecu and the dials - this led is controlled by the ecu.
Yeah well tbh I did wonder why when my car gives out codes like my misfire etc it doesn’t come up with a check engine light I just randomly plug in my OBD reader and find out lol I have only had the car a year not sure if has ever been tampered with could it not just be a blown led on the clocks ? If not how could I find the problem thanks mate I never spotted that my self I thought I meant indicators so checked them all 🤣
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #13 ·
Well I done some searching and found that someone had plugged the MIL light going to plug the clocks back and will have to see if it comes in with ignition
99141
99142
 

·
Registered
Joined
·
373 Posts
P0650 is
CAN-Bus Failure - No CAN-Message

You need to come out of the rabbit hole. Good you found that MIL problem but you're not equipped with knowledge and tools to diagnose this one.

I've fixed this exact problem last week, Zafira B 1.6 2006. Water intrusion in UEC, related to fuse for central door locking FE10, which its circuit was making a high impedance connection to the high speed canbus wiring. Could not be fixed by drying the UEC, was too late for.

Pull out that fuse and see if those faults go away. Door locking won't work.
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #18 ·
P0650 is
CAN-Bus Failure - No CAN-Message

You need to come out of the rabbit hole. Good you found that MIL problem but you're not equipped with knowledge and tools to diagnose this one.

I've fixed this exact problem last week, Zafira B 1.6 2006. Water intrusion in UEC, related to fuse for central door locking FE10, which its circuit was making a high impedance connection to the high speed canbus wiring. Could not be fixed by drying the UEC, was too late for.

Pull out that fuse and see if those faults go away. Door locking won't work.
I haven’t had them codes again yet since I cleared them and that was a few days ago now could it of just had a little blip maybe ? Yeah funny mine is a 1.6 2006 Zafira b club they don’t seem very good with water I kept getting water in my back fuse box witch was making my left brake light cut out just had to clean connectors
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #19 ·
I asked about the blue hue as this is the point where your problem might start.
Nope I knew I hadn’t touched any of the warning light smd’s when I changed them as I wanted them to still be yellow/amber but I have sorted it now someone filled the hole with silicone where the mil light smd was. so guy who sold it to me must of known it had a problem lol
 

·
Registered
Joined
·
364 Posts
What I was referring to was that when you changed the backlight you had to remove the dials, so there was a possibility that the problem started at that point.

But follow what @TTT is saying.
 
1 - 20 of 39 Posts
Top