Vauxhall Owners Network Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi,
I had this van since last October, which seemed to have low mileage which I checked with online MOT history.
Needed to replace the oil sump pan in January as it got cracked when parking in the snow (hit a small hidden ridge).
Ouch. That was an expense I could have done without.
Soon after this the clock and speedo digital display went weird with hardly anything showing... for the first week or so it improved after a few miles but now is totally unreadable. Not a huge problem right now but I'd like to sell it at the end of this year, and the new keeper will obviously want to know the mileage before buying it.
Anyone had this? Can the display be changed or fixed?
Many thanks!
 

·
Registered
Tigra Twintop 1.8 Manual 2009
Joined
·
43 Posts
Hi,
I had this van since last October, which seemed to have low mileage which I checked with online MOT history.
Needed to replace the oil sump pan in January as it got cracked when parking in the snow (hit a small hidden ridge).
Ouch. That was an expense I could have done without.
Soon after this the clock and speedo digital display went weird with hardly anything showing... for the first week or so it improved after a few miles but now is totally unreadable. Not a huge problem right now but I'd like to sell it at the end of this year, and the new keeper will obviously want to know the mileage before buying it.
Anyone had this? Can the display be changed or fixed?
Many thanks!
I thought I had the same problem on my Tigra,
I have no clue about the Vivaro but I knocked the dimmer switch down like an idiot
So couldn't see the mileage and the clock until night and put my lights on and all was dim

Just a thought?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
I thought I had the same problem on my Tigra,
I have no clue about the Vivaro but I knocked the dimmer switch down like an idiot
So couldn't see the mileage and the clock until night and put my lights on and all was dim

Just a thought?
Thanks for your reply... this one is definitely a fault with the lcd, as the display is still bright but unreadable as half the digits are missing. I did have a picture of this somewhere so will try and find it. After doing some research last night it might be that the lcd ribbon could need replacement... I hate digital stuff!
 
1 - 3 of 3 Posts
Top