Vauxhall Owners Network Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi All,

Just joined the network, hoping someone can give me some advice. Sorry if I am covering old ground.

I have a 1997 Vectra CDX 2L Auto Saloon, which I purchased last September. It's been really good so far.

I have 2 areas of concern, and any advice would be much appreciated.

The engine electronics warning light has started coming on and going off, apparently randomly, and the engine has started to occasionally cut out. This is only occasionally and only when I am slowing down at a roundabout or to take a corner - somewhat dangerous.

These problems are not occuring at the same time.


Firstly to the engine electronics warning light.

Yes I have read the owners manual, and am now left with uncertanty as to if I should be concerned or not. I quote "Do not drive for a lenghty period with the indicator illuminated. If it lights up briefly and goes out again this is of no significants."

OK then, how long is briefly ?

How long is a lengthy period ?

The light goes out as part of the ignition sequence; it may then come on after only 5 minutes driving, and stay on for 5 minutes, or it may not come on for 30 mins and then go out after only 10 seconds. It appears to be totally random.

I am not noticing any change in performance, but then most of my journies are on country lanes.

However, I have noted that prior to this light starting to come on and go off, the car was achieving around 340 miles to a tank full, this now appears to have increased to around 400.

This has only appeared in the last week.


Now to the engine cutting out.

As stated above, it appears to bear no relation ship to the engine electronics warning light coming on and going off, other than obviously all the dash lights come on when the engine cuts out.

This has only happened about 5 times in the last month. Prior to that, no problems.


Any comments / advice please.

Cheers
Dave.
 

·
Registered
Joined
·
136 Posts
hello mate, if you have a look around the cutting out is very common it is basically the inlet manifold has got clogged up with gunk stripped it down and give it a good clean out with carb cleaner and check the icv (idle control valve) as that gets gunked up to as it happened to my veccy, with the eml (engine management light) could be a thousand and one things you could spend/waste money by taking it to vauxhall an have then check the ecu out but just have a good look round the engine bay for any loose plugs or corrioded plugs as again i had the eml on constantly with mine then i found the air flow sensor plug was disconnected and that solved it hope this can be of some use to you
 

·
Registered
Joined
·
122 Posts
most probably crankshaft sensor have done loads that cut out as you slow down and turn, you will find the car gives a little jult before the light comes on. still best to get it read as i don't want to waste your money.
 

·
Registered
Joined
·
26 Posts
Sounds like exactly the same symptoms I had on my '98 1.8LS which turned out to have a completely knackered crankshaft sensor with all the insulation cracked and missing at the sensor end so that the wires were shorting out more and more frequently as time went by.

You should be able to check the ECU fault codes as explained in the link below.

If you get "0335", it's well worth the £25 to get a new crank sensor first as they are famous for falling apart...

http://www.topbuzz.co.uk/info/fault_codes/fault_codes.htm

Yours might be a bit of a pig to get at if you've got AC and Power Steering as the engine accessories bracket can partially obscure the sensor. The link below was very helpful to me..

Make sure you've got a set of STAR sockets first!

http://www.topbuzz.co.uk/info/crankshaft_sensor/pic001.htm

Hope this helps!
 
1 - 5 of 5 Posts
Top