Vauxhall Owners Network Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Hello,

My Vectra is 2001 2.0 petrol 16v year and i buy it before 6-7 month from a guy. It was fine but last month i feel like the performance is not as it was... and what i notice RPM is limited to 4000 it's not going over. What could be, what i have to check?
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #3 ·
Is it limited to 4K exactly as in a limp home mode or is it slightly different each gear?

I ask as my insignia did the latter when the cat was breaking down and blocking the exhaust.
i don't know if it's different in gear, how to test it? car should be in drive or there is a trick?

what i'm trying is car started without gear in free mode and tapping on a gas and max its going to 4k~ rpm no more...
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #5 ·
Try it when driving not in neutral.
when i was on a highway car didn't go over 170 KM/s when i tried to go over the started to shake like it want to go over but something was holding it... weird sound like car can\t breath enough.. i guess that's a problem.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #7 ·
Could be the issue with the cat like I had.

My local garage took the lambda out and ran it up. Cat was glowing red hot
can you describe it more i don't understand what is cat and lambda? i guess that shortcut from some long words :)...
 

·
Team Tommy Tank!
Joined
·
4,415 Posts
can you describe it more i don't understand what is cat and lambda? i guess that shortcut from some long words :)...
The catalytic converter had broken up and blocked the exhaust.

There is a sensor in the exhaust called a lambda sensor. By removing it you could see that the exhaust was blocked.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #11 ·
Is the engine light on? Sounds like a bad camshaft /crankshaft sensor. They make engine limit at 4500rpm
i just put the car on service for check, they just put the car on computer and it shows like non functional camshaft sensor. I just switch it with after market one but same problem appears again.... maybe it's not original but its a new sensor and its not working even with or without the sensor car is limited to 4500 RPM. what or how i can test if the sensor is working?

another problem is car performance is not good it's like very slow car but it's 2.0 engine acting like 1.0 engine even worse.. it was very fast car at the months...
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #12 ·
I buy and put the original siemens cam sensor and car back to good performance. Thanks everyone.
 
1 - 12 of 12 Posts
Top