Vauxhall Owners Network Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Vectra C Direct on a 55 plate. Car began juddering around 4000rpm, then anytime near the accelerator pedal it jumped into limp mode, had fuel filter, plugs & coil pack maf sensor & fuel pump. It's now out of limp mode but if I press any harder than about 5mm on accelerator it judders & goes back into limp mode. No fault codes are appearing. There is only 2 things I can think of left, accelerator pedal or the injectors. Has any one had any of these problems please help.... Thanks Tommy
 

·
Premium Member
Joined
·
1,343 Posts
High pressure fuel pump or fuel regulator. Usually brings up code p1191. 9 times out of 10 it's the high pressure fuel pump.

Is yours the old siemens brand? It was later updated by a continental one due to the diaphragm failures.
 

·
Registered
Joined
·
50 Posts
@TommyLadUK sounds like your having same issue as mine, I've already done the process of swapping sensors, checking everything even injectors are fine. you need it scanned man, and some data logged. could turn out to be a High pressure pump, which i think is the issue with mine. don't go buying injectors just yet, also does your fuel rail sound noisy? ~ another indication its low fuel pressure.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #6
thanks for replies, the high pressure fuel pump has been replaced as code for it was pinging up, along with misfire on cylinder 4, then coil pack was replaced. Has the fuel sensors changed & fuel filter. No codes are present, have got it out of limp mode by revving through judder to 3000rpm then 1st gear softly. Judders to about 2000rpm then smooth until 3500rpm then limp mode. Having a new accelerator pedal in the morning. Haven't consulted my mechanic about thos.... But could it be catalyc converter blocked?
 
1 - 6 of 6 Posts
Top