Vauxhall Owners Network Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Hi I am hoping that someone can help me on this.

I have a P reg Vectra. 2.0 GLS.

For the past few weeks my heating system on it has stopped working. I dont just mean the heating aspect but no air (hot or cold) is being blown through. There is no noise or anything it is just totally dead even when you turn the switch to the highest setting!!!

Any suggestions???
Cheers
Mike
 

·
Registered
Joined
·
52 Posts
If the fan isn't running your first port of call is the check the appropriate fuse (sorry, not sure which one it is off the top of my head). If you drive reasonably fast (50 - 60 mph) does air come through the vents, if not, the recirculate thingy may be stuck (again, not really sure how it works but someone on here will)

hope thats helpful as a starting point.

Pete
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #4 ·
Heating fuse

Yeah air does come through when you are doing speed on the motorway etc, but otherwise nothing.

If it is the fuse does anyone know which one it is?

As you can tell im not mechanically minded !!!!
 

·
Banned
Joined
·
1,028 Posts
Hi I am hoping that someone can help me on this.

I have a P reg Vectra. 2.0 GLS.

For the past few weeks my heating system on it has stopped working. I dont just mean the heating aspect but no air (hot or cold) is being blown through. There is no noise or anything it is just totally dead even when you turn the switch to the highest setting!!!

Any suggestions???
Cheers
Mike
This could be due to a blown heater switch, it may be worth checking because I have had lots of Vaux heater switches blow over the years.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top