Vauxhall Owners Network Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hi guys,

I'll try make this as short as possible. A couple of issues:

I've had my van, the Vivaro 2900 DI SWB (1.9) for about 5/6 years now (mainly just used to take my dog out tbf) but for the last 13/14 months it's sat still as I had a company van.
End of December I started work on it to get it ready for an MOT. Mainly a few bulbs that had gone, and the brake system. I replaced the pads, discs etc then bled the brakes.
However, the pedal still goes to the floor. If you pump it then it'll stop pumping eventually and be firm but when you pull off then it goes to the floor although slightly works still but oviously not good enough (handbrake is fine).. am I correct in thinking the servo could be knackered? I'm hoping there could be another possibility to try before I have to source and change the servo.
If it helps, I can hear air pumping when I press the brake pedal down yet there isn't any air bubbles when I bleed them?

Second issue.. when I first start the van it's fine and I could drive it to Scotland and back if I fancied but if I turn it off and then back on, the glowplug light flashes on and will also restrict it's power. If I leave it off for say 10-15 minutes and turn it back on then the issue is cleared and will work again until I turn it off and then back on again too soon.. any ideas what could be causing this?

I have noticed that mice have been living in the engine bay (it's parked down the bottom of my drive and is very dark etc). They've chewed through some soundproofing etc round the edges and they've made two 'nests', one on either corner of the chassis. I've cleared these out now but I'm hoping they haven't chewed through any electrics so does anyone have any idea about the glowplug issue? I can't see any damage to any visible cabling on the loom but understand it could be further down the line.. but the issue clears if you leave the van off for a little while.

I'll upload the photos of what the three blind mice have been up to while it's been sat just for the luls but if anyone has any ideas then let me know and I'll see what I can do.

Cheers in advance.

Pic 1: Hole in the felt (They've chewed a lot more than this going by the amount in their nests but unsure where yet)



van1.jpg



Picture 2: Nest 1



van2.jpg



Picture 3: Nest 2



van3.jpg



Picture 4: One nest cleared



van4.jpg



Picture 5: Nest number 2 cleared out



van5.jpg
 

·
Registered
Joined
·
123 Posts
No idea with the flashing glowplug light. You really need to connect a reader and get the codes.

Some vehicles are a pain to bleed. All I can suggest is persevere, buy a litre of brake fluid and keep bleeding all 4 corners until things have improved. I wouldn't have thought the servo is to blame.
 

·
If you want to save fuel buy a Camel & a shovel
Joined
·
350 Posts
When you say you can hear air. Is this with the engine turned off. If so then that is quite normal. The pedal feel is a bit weird on the Trafic. If the pedal is ok with the engine running give it a steady try out & see. The Glowplug issue I don't have a clue. But that said why would you want to sw off the ignition & then straight back on.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
When you say you can hear air. Is this with the engine turned off. If so then that is quite normal. The pedal feel is a bit weird on the Trafic. If the pedal is ok with the engine running give it a steady try out & see. The Glowplug issue I don't have a clue. But that said why would you want to sw off the ignition & then straight back on.
Hi mate.
Even the sake of parking outside a shop to get something then I have to wait until it cools down before the light will go and not leave me in limp mode.
A mate of mine has lent me Renault CLIP (which I’ll later use to cycle the solenoids and remove any air) but I’m just trying to work out all the details to connect it.
I know the engine is the F9Q but it appears that’s in a few models.
One problem I’m having is knowing what “Trafic” my Vivaro is. The 1, 2 or 3. It’s a 55 plate if anyone has any ideas? Cheers
 
1 - 5 of 5 Posts
Top