Vauxhall Owners Network Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hi guys I'm trying to get to the bottom of a issue I've been having with my car for a few weeks now, after many hours researching and a few trips down the garage, plus a few hundred quid later I'm still at a loss with it.
I started having issues with loss of power, I have a 2013 model zafira with the eco turbo engine, we thought the fault was clogged up dpf at first, so had that cleaned and flushed out, now I've just had the EGR done which was pretty clogged up too. However on my way home I was still having issues, was on a 60 road and struggled to get to 40 in third gear, power dropped and I had to drop into second gear to pull my car away from the car that nearly rear ended me due to loss of power, its also struggling for power up hills. Its usually pretty beefy due to the turbo, but even with my foot to the floor it's just not happening.. No issues coming up on diagnostic machine. I've done pedal test which is showing three different codes on the ECN (was only two codes there before I had the EGR cleaned out) does anyone have any insight at all what my issue can be, it's driving me crazy now. Thank you to anyone who takes the time to reply and help.
 

·
Super Moderator
Joined
·
26,857 Posts
Just a couple of early questions
What engine is in this Zafira ?
Don’t think the pedal test works on these.
What make of scanner is the garage using ?
It does sound like how my old 1.7 DTI ran when the MAF started failing , loss of power , dropping down gears to get it to go etc.
 
  • Like
Reactions: Boroboy

·
Registered
Joined
·
7 Posts
Discussion Starter #3
It's a 1.7 eco turbo engine that's all I know about the engine itself, not very clued up with cars haha. I've got a electronic display on my dash which shows my milage and when doing the pedal test it brings up ECN and its now showing a series of error codes. I didn't know the pedal test was a thing til I researched and found videos on YouTube. As for the diagnostic scanner I have no idea what make it is it was bringing up codes before the DPF and EGR was done but now nothing. They are scratching thier heads down there while I'm ripping my hair out.
 

·
Super Moderator
Joined
·
26,857 Posts
This is the newest code it brings up
That’s saying DPF pressure sensor or something similar , so it does have a fault code logged.
The garage obviously hasn’t got good enough equipment to read the engine management system.
 
  • Like
Reactions: Boroboy

·
Premium Member
Joined
·
2,514 Posts
As Fred says, the garage hasn't got a code reader that works properly with Vauxhalls.
You need to get it scanned with opcom or Tech2 (Vauxhall's own system).
 

·
Registered
Joined
·
7 Posts
Discussion Starter #7
That code has only come up today after cleaning, prior to that code I have
043507
And
029952 which are also still on the dash. I would have thought with the EGR and dpf being fully cleaned it i wouldn't have this issue. There's no way this car is going to make it to my local vaxhaul, it's loosing too much power
Sis in law seems to believe its the mass flow meter which by researching seems to show similar symptoms but I'm not sure
 

·
Worn Out Member
Joined
·
6,440 Posts
In cleaning the dpf you're tackling the effect rather than the cause,if the pressure sensor fault is present the dpf has lost one of it's main inputs for calculating how blocked the dpf is,it will probably stop it regenerating, I'd recommend checking the sensor and pipework and fixing it . It's also probably best to tell the ECM that the dpf has been replaced once the sensor is confirmed as ok,this will allow the ECM to recalculate the dpf soot loading strategy.
 

·
Premium Member
Joined
·
14,472 Posts
After every clean the dpf data should be reset and then the car taken on a extended road test to confirm, amongst other things,.. boost, egr , coolant temps and above all that it does a regen otherwise its only half a job. Who done the job, do you know if they confirmed the dpf will now regen, were you given a report on the engine and dpf condition, did they confirm why it blocked in the first place and any recommendations for remedial work to help maintain a healthy dpf.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #10
Andy it was all reset when the DPF was cleaned, and I ran it on the motorway, but the second I got on the motorway the light came on (car with spanner light) and it was up and down power wise, them went into a state like limp mode for a while, was very jumpy on the roads after looking on here I found alot leading to the EGR hence why I've also had that cleaned too. And with the state it's at now I would have a death wish to even attempt the motorway, it just doesn't have the power to reach the speeds needed, I'd end up in a accident. By the way I really appreciate all these replies guys thank you for taking the time to reply to me
 

·
Super Moderator
Joined
·
26,857 Posts
Andy it was all reset when the DPF was cleaned, and I ran it on the motorway, but the second I got on the motorway the light came on (car with spanner light) and it was up and down power wise, them went into a state like limp mode for a while, was very jumpy on the roads after looking on here I found alot leading to the EGR hence why I've also had that cleaned too. And with the state it's at now I would have a death wish to even attempt the motorway, it just doesn't have the power to reach the speeds needed, I'd end up in a accident. By the way I really appreciate all these replies guys thank you for taking the time to reply to me
Jumpy / jerky is how my mates Astra J 1.7 cdti was before he had a new DPF fitted , so it’s a good bet yours is still blocked & strangulating the engine.
 
  • Like
Reactions: Boroboy

·
Registered
Joined
·
7 Posts
Discussion Starter #13
Just an update for anyone who wanted to know or future readers I took it to another garage for a second opinion to see if they could find the problem, they found the issue almost immediately, turns out its actually my turbo boost pipe has split all the way down the front and has oil leaking from it. Best part... The part is only £105 straight from vauxhall. Thank god we got there in the end!!
 
1 - 14 of 14 Posts
Top