Vauxhall Owners Network Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Can anyone help with a problem iv got on my twintop roof please.
Last week why I was having a look to see why the roof wouldn't work I opened the boot to look at the wiring on the left hand hinge all that was good.
The boot opened as normal but when trying to open the roof the boot lid would only lift up and then it would stop. So I used the 5mm allenkey and pulled the 2 manual cords to have a look to see if there was somethink els going on. Now iv put it all back and now the boot wont open.
Iv plugged Opcom into it and I get a fault code of B130F-5A Trunk lid switches not plausible....can anyone tell me with switches this is please.
 

·
Registered
Joined
·
24 Posts
Have a look at this thread it sounds like you also need to power probe the yellow relay.
lol shall I add the link!

 

·
Registered
Joined
·
6 Posts
Hi all, this is my first post, happy to be on board, sorry to say I dont have alot of knowledge of cars, and can really do with some help and advice about my Astra twintop Design 2009, firstly a dodgy mechanic told me to open my roof, when I'd already told him it's not working, it got stuck, I had to look at youtube for help.
He said the diagnositic error was B130F-5A Trunk Lid Switches Not Plausible, not a clue what that means, after that the boot wouldnt close, now the boot wont open and lastly why do I get condensation on the back seats and floor is wet when it rains. I'm desperate for help!!! I look forward to hearing from you, thank you !!
 

·
Well-known member
Joined
·
14,887 Posts
Better to start your own thread than jump onto someone else's, that way it is less confusing for those that want to help.
 
  • Like
Reactions: Alan G H

·
Registered
2006 Vectra C 1.8, 2008 Astra Twintop 1.8
Joined
·
132 Posts
Hi all, this is my first post, happy to be on board, sorry to say I dont have alot of knowledge of cars, and can really do with some help and advice about my Astra twintop Design 2009, firstly a dodgy mechanic told me to open my roof, when I'd already told him it's not working, it got stuck, I had to look at youtube for help.
He said the diagnositic error was B130F-5A Trunk Lid Switches Not Plausible, not a clue what that means, after that the boot wouldnt close, now the boot wont open and lastly why do I get condensation on the back seats and floor is wet when it rains. I'm desperate for help!!! I look forward to hearing from you, thank you !!
The boot won't open if there is a fault anywhere in the roof system. There are a bunch of things that need to be in the right setting for the system to work, if anything is not reading correctly to the roof ECU it disables the system, including the boot solenoid.
If you can disconnect the roof ECU, you will be able to open the boot, the ECU is located rather helpfully in the boot! It is on the drivers side just behind the rear seat under the carpeted trim, if you have long arms you may be able to reach it through the ski hatch, alternatively, get an Opcom diagnostic unit (speak to @Koicarpkeeper on here), through the diagnostics you can open the boot, it will also be really helpful to diagnose the issue with the roof system and give you an idea where to look and what sensors/switches might need resetting.
 
1 - 7 of 7 Posts
Top