Vauxhall Owners Network Forum banner

1 - 20 of 30 Posts

·
Registered
Joined
·
145 Posts
Discussion Starter #1
I'm in the middle of doing the omega sunroof conversion at the minute which is simple enough but i need your help (again:lmao: ).

the omega facia that i got from the scrappy was cracked but i took it anyway as i already had a facia at home but the problem is removing the ecu from the back of the old facia to go on the new one. it looks as though i need to seperate the selector dial from the switch to allow the ecu to come free but i don't want to break it or put on the cracked facia so any help would be appreciated?

hope taht makes sense
 

·
Premium Member
Joined
·
6,156 Posts
if i remember correctly the switch just pulls out. Then you can take the motor off the back.
 

·
8v Power!
Joined
·
10,748 Posts
if you hold on 14 day's I'llbe able to tell you :D
 

·
Registered
Joined
·
145 Posts
Discussion Starter #4
:lmao: well the motor is allredy bolted to the cav but the ecu is still attached th the facia the problem im having is getting the ecu off so i can put it in the black box on the motor but i can't get the dial off the front of the damn facia:rolleyes:
 

·
8v Power!
Joined
·
10,748 Posts
Leehollingworth said:
:lmao: well the motor is allredy bolted to the cav but the ecu is still attached th the facia the problem im having is getting the ecu off so i can put it in the black box on the motor but i can't get the dial off the front of the damn facia:rolleyes:
got pictures of both ends?
 

·
Registered
Joined
·
145 Posts
Discussion Starter #6
showing so far!
[/URL][/IMG]
The bit i need to get off the old facia!
[/URL][/IMG]
and the offending switch i need to remove to get it off!
[/URL][/IMG]
hope this clears up what im asking sorry it took so long, cheers
 

·
Banned
Joined
·
14,579 Posts
You just pull the knob and off it comes :lmao:

Then depress the 2 black clips and the motor/ecu comes away
 

·
Premium Member
Joined
·
6,156 Posts
Andy M said:
You just pull the knob and off it comes :lmao:

Then depress the 2 black clips and the motor/ecu comes away
Could have told him that 5 mins ago :lmao: it's cold out there.
 

·
VXON SirTalkalot
Joined
·
4,635 Posts
i have 1 in front of me and i`m yet to fit, the knob as a kinda pin that holds it on, but i just pulled myne and it came off, then you can see a black bit with which if you pinch and push, you are a winner
hth
 

·
Registered
Joined
·
145 Posts
Discussion Starter #11
been trying to pull it off and no go looks like its gonna break so im gonna finish my brew and then i'll have another go!

its easy to say just pull it when you no thats what to do and know you aint gonna break it:rolleyes: :lmao: :lmao:

cheers guys
 

·
VXON SirTalkalot
Joined
·
4,635 Posts
can u lever it a bit so you can see the pin, if you can try and pull the clip, its like a hair clip or retaining clip i think they are called, hth
 

·
Gas Powered
Joined
·
15,285 Posts
you must have pulled the knob off to remove the motor from the Omega, unless you broke it off.
 

·
Registered
Joined
·
145 Posts
Discussion Starter #15
Fitted the damn thing and it aint working and the map reading lights dont work eighter but the curtasy light dose so i need to check the wiring again tomorrow.
 

·
Registered
Joined
·
145 Posts
Discussion Starter #16
Been out this morning to try and make the sunroof work. ive tested the wiring at the plug that go's into the motor and found-
pin 1 - is live +12v
pin 2 - is Earth
pin 5 - is live only when ignition is on
with the other three running down to be wired up to the alarm closure etc.
but i turn the switch and nothing:shame: could this be that the motor i got is f**ked or is there somthing im missing, also the 2 map lights don't work?

any help would be appreciated:Cool2:
 

·
Registered
Joined
·
145 Posts
Discussion Starter #18
:Cool2: Cheers mate i think im gonna stop posting on here cos every time i do i just look a c**t:lmao: :lmao: didn't realise it pushed in just assumed that it was a miss print in the how 2, then again assumption is the mother of all f**k ups. lol
 

·
8v Power!
Joined
·
10,748 Posts
nah, don't its all learning ain't it :D
 

·
Registered
Joined
·
145 Posts
Discussion Starter #20
Envoy CDX said:
nah, don't its all learning ain't it :D
ALL being the right word:lmao:.
still can't understand why the map lights don't work though? not even on the old light:grrr i'll have alook later then no doubt i'll be back:rolleyes: :lmao:
 
1 - 20 of 30 Posts
Top