Vauxhall Owners Network Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Greetings!
I have a swaith of daft questions, as my new project is to sort out my 94 omega estate (2.5v6)

1)flat spot at 4000 revs when accelerating hard- any ideas?

2) What water temp should it run at? (neurotic as last 2 cars died of cooling issues)

3) fitting ECU off a 3 litre lump- make any difference to performance?

4) Cruise control- is it retro fittable?

5) same as 4 but for air con?

6) Same as 4 & 5 for traffic master orracle?

7) MID with corrupted display- how do i get it out to change?

Thanks in advance, I hope somone will be able to help me!!!
ttfn
Dan
 

·
Premium Member
Joined
·
1,294 Posts
My temp guage always went up and down all the time but never over 100 degrees. As long as the fans come on and it doesnt go into the red you should be ok.Averaged 95 degrees.
 

·
Registered
Joined
·
351 Posts
The flat spot might be the rear multiram, there is a quick check here:
http://www.vauxhallownersnetwork.co.uk/showthread.php?t=97268

Water temp should be around 95-97 but may well go up and down a bit as it plays around with the fan speed.

The 3.0 ECU is the same as the 2.5 one. There was a later version that also had a sensor for the power steering and adjusted the timing or something but I suspect you have the earlier one.

Cruise control can be fitted, search for the threads. How I fitted my module is here http://www.infohitsystems.ltd.uk/Gallery/car_photo.sh?path=Car (pics 22-25), for an auto you may need a 4 pin brake switch, for manual that and a clutch switch and of course a new indicator stalk with the cruise control buttons. Don't mix it up with the later drive by wire ones, for the '94 model you will need the module.

Can't help with the other questions really but retro fitting aircon will be a major job. I get the feeling that trafficmaster isn't worth it. MID has been discussed a lot, do a search.
 
1 - 3 of 3 Posts
Top