Vauxhall Owners Network Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Got an 09 Astra twintop put the roof down yesterday no problem tried to put it back up no problem until the last second when it didn’t beep to say it had finished so went out to check and my boot was slight opened tried to close it but wouldn’t, tried to put roof up again it 3 bongs and could hear a motor running as if it wasn’t finished! I can use it with roof down but it just won’t let me drive it with roof up keeps binging and bleeping at me and no boot access
 

·
Premium Member
Joined
·
14,447 Posts
It sounds like the roof is not closed and locked correctly, do you have Opcom diagnostic.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
It sounds like the roof is not closed and locked correctly, do you have Opcom diagnostic.
No I’ve nothing to diagnose the problem it seems the hinge mechanism isn’t falling back into place to allow the hinge to disengage
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
Just been told the sensor once the roof is up is not telling the boot the roof is closed and to finish up! The garage can’t fix it so stupid question where is the sensors for the roof engage and where do I get the sensors
 

·
Premium Member
Joined
·
14,447 Posts
I would be quite confident in saying it wont be the sensor, it never is, all the time i have done one its always been a broken wire, the best way forward is to buy yourself Opcom, this will allow you to open the boot to gain access to the loom, it can also read the faults in the roof module and also give you some data showing the position/status of each roof sensor, this is vital to understand whats wrong and which bit needs repairing.
 
1 - 8 of 8 Posts
Top