Vauxhall Owners Network Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 · (Edited)
Hi corsa excuses my spelling.


I have a 01 1.4 corsa auto. The corsa used to drive fine till a few months back when the speedometer would intermittently stop working. It slowly got worse to now maybe ones a week it works if that. When it works it works for the hole trip. I also noticed it seams to be lighter sterling left then right and the power sterling is not at its best when the speedo not working. also I have a light on the dash. I took it to my normal garage and he told me it would be hard for him to fit it in as it would be falt finding the problem. So I did some research. I am fine with working on my own cars I did a THROTTLE+BRAKE+IGNITION test witch brought back some falt coads.

0500
1616
2106

Could you help me figure out what need to do to fix my problem.
 

·
Worn Out Member
Joined
·
9,480 Posts
 

·
Well-known member
Joined
·
17,862 Posts
Do you have an ABS light illuminate on the instruments when you turn the ignition on?

Or put the car on full lock and look for a cable running from the body to the wheel hub.
 

·
Worn Out Member
Joined
·
9,480 Posts
afair all the Corsa C's had a speedo driven from a nearside front abs sensor regardless of if it has abs or not
 

·
Well-known member
Joined
·
17,862 Posts
In which case best to see if there is a cable going to the front offside hub then.

Or post your registration number up or VIN and someone can check if the car has ABS or not.
 
1 - 7 of 7 Posts
Top