Vauxhall Owners Network Forum banner

1 - 10 of 10 Posts

·
Cannonball will win with or without you
Joined
·
8,417 Posts
Discussion Starter #1
I hate the bloody thing , hate it :grrr
Right I've had this boost problem ever since I put the thing on the road . It has come and gone occasionaly but it's still there .

The car wont boost over 10-11psi without juddering and holding back > pushing and pulling .

If I set my mbc to 10 psi the car is fine , it boosts perfect .

As soon as I try and go over 10-11 psi the car just judders .

It will boost past 10-11 psi but it judders all the way there .

I'm even considering taking it into somewhere which I don't want to do .

I got another amal valve from a friend to see if it works using standard methods today but it wont hold boost past 10-11psi .

I got some phase2 chips as I was told it could be hitting the standard ecu boost limit but still runs **** .

Could it be an actuator problem ?

Sorry for the long post but this has been months .
 

·
Cannonball will win with or without you
Joined
·
8,417 Posts
Discussion Starter #2
Listening to Slayer loudly -good for when you are annoyed :grrr
 
C

·
Guest
Joined
·
0 Posts
Could try a helper spring on the actuator.
What states the turbo in? Maybe it's not healthy enough to buil that much boost.
 

·
Registered
Joined
·
28 Posts
i am not familiar with any vauxhall turbos but..........does it have a fuel cut? the toyotos i drive all have them, once you go over 11 psi the sensor delivers more than 4.4volts to the ecu and bang. it's like hitting a curb at 60. no more go. remedied by purchasing a fuel cut defender for about 100 quid and then the boost can be pushed up to around 30 as oppossed to the stock 6
 
C

·
Guest
Joined
·
0 Posts
With the chips can go to 22 psi, no other mod needed to achieve this ( however risky that may be).
 

·
Registered
Joined
·
28 Posts
well you are obviously hitting a limit at 11 psi, i don't know what. it seems very precise to be fine at 10 and no where at 11. if the turbo or wastegate was faulty/old/worn out then you would probably have a tailing off of the boost and not a definate limit, i still think your problem is electrical mate
 

·
AKA Cavgsi4x4turbo
Joined
·
5,260 Posts
daddy cav said:
I hate the bloody thing , hate it :grrr
Right I've had this boost problem ever since I put the thing on the road . It has come and gone occasionaly but it's still there .

The car wont boost over 10-11psi without juddering and holding back > pushing and pulling .

If I set my mbc to 10 psi the car is fine , it boosts perfect .

As soon as I try and go over 10-11 psi the car just judders .

It will boost past 10-11 psi but it judders all the way there .

I'm even considering taking it into somewhere which I don't want to do .

I got another amal valve from a friend to see if it works using standard methods today but it wont hold boost past 10-11psi .

I got some phase2 chips as I was told it could be hitting the standard ecu boost limit but still runs **** .

Could it be an actuator problem ?

Sorry for the long post but this has been months .
have you got a boost guage?
have you got a dump valve?
do you get any whissle(sp) when its boosting?
 

·
Cannonball will win with or without you
Joined
·
8,417 Posts
Discussion Starter #8
Yes got a boost gauge no dump valve and the whistle comes from my cone filter . :Cool2:
 

·
AKA Cavgsi4x4turbo
Joined
·
5,260 Posts
have you got a std air box to it for a little while? a boost leak would cause your problem. if you are 100% you havent disconnect the pipe on the actuator (this is well iffy) then go out for a carefull drive and see ifyou get over 11psi boost but remeber there is nothing to limit boost.if you get over 11 its not mechanical its a electrical or pipework.
 

·
Cannonball will win with or without you
Joined
·
8,417 Posts
Discussion Starter #10
Ok I'll have a mess about tomorrow and see :Cool2:
 
1 - 10 of 10 Posts
Top