Vauxhall Owners Network Forum banner

1 - 20 of 31 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hi all. I believe I have a problem with my ECU.
Recently the car has been loud, as if I have put a cone filter on it, but no changes have been made to the car. Running really rough and burning fuel like there's no tomorrow. Already checked and there's no signs of leaks. After letting my mechanic look at it, it isn't throwing any fault codes but check engine light comes on occasionally.
Hits about 3500 RPM and refuses to accelerate in any gear after that, takes about 2 minutes to get from 40-60 on motorways etc.
I took the ECU out to inspect physical condition and it looks great, no sign of corrosion or water ingress and better than nearly all the second hand ones I have seen. I have ordered a new ECU but will need reprogramming. Just wondering if my ECU has killed its software and needs resetting rather than replacing?
We are going to assume here that I have zero tools to go about this, and have no codes or pins for either ECU, all I have currently is the numbers printed on the ECU
Anybody be able to basically give me an idea of where to get started, or just chuck it to my mechanic and let him deal with it?
Where can I get the codes and what tools/ software would I need to do it myself?
Car is 2013 1.4 Petrol SE 5 door
5 Speed manual
ECU numbers are E83 55590556 86ABH054231900TK this is the same for the replacement
Huge thanks in advance!
 

·
Well-known member
Joined
·
13,316 Posts
What model is this 5 door manual?
 

·
Worn Out Member
Joined
·
6,161 Posts
Those symptoms don't shout out faulty ecm to me,
as a start i think i'd be checking the cam cover pcv isn't gone causing excess crankcase vacuum
 
  • Like
Reactions: twbk199

·
Registered
Joined
·
15 Posts
Discussion Starter #5
Just starting out with looking at cars in the mechanical sense, Mechanic said had an astra in that did the same thing and the ecm was mashed. I'll have a look for what you said and see if symptoms match
Will update if i find anything
 

·
Worn Out Member
Joined
·
6,161 Posts
Easy enough to check,run it on tickover for a few minutes and see if the oil cap will come off easily or not,
normally a faulty ecm will leave a trail of fault codes,
of course that does depend what was used to read them as not all scanners work 100%,
but even a basic obd reader will pick some of them up
 
  • Like
Reactions: twbk199

·
Registered
Joined
·
15 Posts
Discussion Starter #7
Watched a video and it defo seems like that could be the case, car had exact symptoms as mine, and I had literally zero fault codes from 2 mechanics, ill force the EML on with a scanner on by trying to accel past 3500 RPM and see if it gives the P0170 code or something. Will also do what you suggested
Already seems like I'm onto something.
I'll let you know how it goes when I get out of work
 

·
Worn Out Member
Joined
·
6,161 Posts
You won't always get a P0170,depends how bad the vacuum is and how long it's run like like it
 
  • Like
Reactions: twbk199

·
Registered
Joined
·
15 Posts
Discussion Starter #9
Been running like it for about a month roughly, due to finances and not being able to get time off work as only form of transport but have kept the driving to a minimum, will have a look and let you know tomorrow,
Thanks for the help
 

·
Premium Member
Joined
·
14,127 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #11
Perfect, I have ordered the part regardless of being able to test my current one as its common for them to fail, so a pre-emptive replacement can't hurt if it is working. I will post when I have fitted the new one with an update, absolutely fantastic help on here and will probably end up posting about something else soon!!
 

·
Worn Out Member
Joined
·
6,161 Posts
Also correct me if wrong but 1.4 SE 13 Plate is A14XER engine right?
Most likely it is if it's normally aspirated and not a turbo,
but as far as i can see you haven't actually said what car this is,( it could be an Astra J,Insignia A, Corsa D,Meriva B)
 

·
Worn Out Member
Joined
·
6,161 Posts
Nope still don't see what it is Andy :)
 

·
Premium Member
Joined
·
14,127 Posts
My Bad... you mean what car, well i assumed it was the Corsa D,.. dont see the Astra with this fault that often strangely enough,... maybe the valve is worked harder on the Corsa so fails early.
Maybe i should read things more carefully and not assume what car it is,...
 

·
Worn Out Member
Joined
·
6,161 Posts
Strangely enough i originally assumed it was an Astra whereas you went for a Corsa,
it's probably a bloody Meriva 🤣
 
  • Like
Reactions: andyl

·
Well-known member
Joined
·
13,316 Posts
I asked the OP and he confirmed it was a 5 door 5 speed manual!
 
1 - 20 of 31 Posts
Top