Vauxhall Owners Network Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
Bought opcom from Amazon. Got it’s all installed along with the drivers. If I scan the body module I can see all the measurement fields such as wipers indicators etc no problem.

if I try the engine module nothing shows at all. If I run a fault scan on it, it says almost everything has a fault. This is on a 2006 2.0 vivaro

anyone know how I can resolve the issues

thanks.
 

·
Well-known member
Joined
·
15,367 Posts
Probably a faulty relay.
What channel is the body module on and what channel is the engine on?
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #3 ·
It just seems to auto select pin 7 I believe. Should I be doing it differently. Trying to trace a p0235.
 

·
Well-known member
Joined
·
15,367 Posts
So are they both on pin 7?
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #5 ·
I need to get it out again and check but am sure they were both the same either pin 3 or pin 7.

was told with the instructions it auto scanned and chose the right channel.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #6 ·
Ok so both connecting on pin 7. If I connect as 1.9 o 2.5 version it does put data in the fields but crap data like mag -77 but nothing on the 2.0 setting.
 

·
Well-known member
Joined
·
15,367 Posts
Then the version you have bought is probably not supporting your vehicle, simple as that.
The Vivaro really needs a decent late model OpCom or Vauxcom running genuine software with genuine firmware to give good access.

Bet you a pound 💷 to a dollar 💵 yours is running some hacked about version with fake firmware like 1.9, 1.95 or 1.99.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #8 ·
Then the version you have bought is probably not supporting your vehicle, simple as that.
The Vivaro really needs a decent late model OpCom or Vauxcom running genuine software with genuine firmware to give good access.

Bet you a pound 💷 to a dollar 💵 yours is running some hacked about version with fake firmware like 1.9, 1.95 or 1.99.
I think it says version 1.99
 

·
Worn Out Member
Joined
·
7,857 Posts
You're going to need at least a 2015 (150406) software for an M9R engine
 

·
Well-known member
Joined
·
15,367 Posts
Chances are with that fake 1.99 firmware you are also running the 120309a software?
 

·
Well-known member
Joined
·
15,367 Posts
You can but it won't run on that unit because it has a fake controller chip. If you install the later software it will update the firmware which will then scrap your unit.
So basically you need a new unit.

I can help but you need more than a piggy bank.
 
1 - 13 of 13 Posts
Top