Vauxhall Owners Network Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi, I don't know if anyone is getting the same issues. My car is going a bit crazy at the moment ! The engine light keeps coming on and it starts to lose power (i.e. turbo boost). The garage have cleared out the turbo but it keeps happening. Then the electrics started to go weird; the temperature said -40, the parking sensor isn't working, the cooler fan comes on after literally one minute in traffic ! The garage have done a diagnostic test and said they are 90% sure it's the turbo boost that needs replacing but take it to a Vauxhall garage for a diagnostic test. I was quoted £264 for the test at Vauxhall so refused. It's now back with my normal garage and I haven't heard anything for about a week. Is anyone else having similar issues or has any idea what it might be?
 

·
Premium Member
Joined
·
15,157 Posts
Which engine is it?
Do you have any fault codes?
Best to have a decent diagnostic done from a decent independent diesel specialist. I'm presuming it's the 2.0cdti engine. Good idea to avoid a vaux garage.
I decent diagnostic from a reputable garage from where I live is around £25.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Hi, it's a 1400 and I haven't seen any fault codes. The garage have run a diagnostic test and said it is showing an issue with the turbo boost but they don't want to change it in case it's something else. Just called them and they have an electric specialist going out to see it tomorrow.

It's petrol not diesel.

The garage have done two diagnostic tests on it already @£70 each but luckily haven't charged me for them as they haven't resolved the issue
 

·
Premium Member
Joined
·
15,157 Posts
Hi, it's a 1400 and I haven't seen any fault codes. The garage have run a diagnostic test and said it is showing an issue with the turbo boost but they don't want to change it in case it's something else. Just called them and they have an electric specialist going out to see it tomorrow.

It's petrol not diesel.

The garage have done two diagnostic tests on it already @£70 each but luckily haven't charged me for them as they haven't resolved the issue
It's the 1.4t then. Hopefully you'll get some more help on here.
 
1 - 6 of 6 Posts
Top