Vauxhall Owners Network Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Driving along this morning, indicated ... oh look, continuous green arrow on the dash and no clicking sound. Same on both sides. Checked in car park - indicator lights on solid, no flashing. Happens with hazard warning too - all four lights on steady.

I searched the forums: some say it could be the hazard switch, but I'd be surprised: it's only been used about five times in the life of the car. Other posts suggest the relay. How hard is that to change and can I get the replacement over the weekend? (I have to be on the motorway at sparrow's fart on Monday morning).

All advice gratefully received. I used to be OKish at cars but that was 25 years ago and they've got all technical on me since then, to say nothing of very crowded under the bonnet ...
 

·
Premium Member
Joined
·
1,089 Posts
Had the same thing when I first got my car, I had it indicating right constant green light but not clicking and had the AA out they took the relay out but then I had no indicators, I took it to Vx and they diagnosed it as having an earthing issue in the main loom. worth getting them to check it over.

So they repaired the main loom been fine ever since.

Hope this helps

Roy
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Marks DTM Calib said:
The common cause is the hazard switch, try turning the hazards on and off a few times to see if it goes away.
Worked like a charm - thank you very much. Cheap fix, too ... :)
 
1 - 4 of 4 Posts
Top