Vauxhall Owners Network Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hey. New to this forum but I have tried looking but I am a bit stumped on what to do next. On my astra H Z16XER (vvt?) I had the red oil light up. So I immediately thought pressure switch. Done a oil change and replaced pressure switch but as of yet red oil light still on and no clue what to do next. Has anyone got any suggestions? I thought the vvt solenoids but that should put a code on the ECU. No codes apart from entertainment one due to aftermarket head unit.

Any help will be very appreciated. I will PayPal the guy who gets it right money for a pint.

Thanks Sam.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
So it's running on 5 bar on cold so been told not pump. Anyone got any other suggestions. Maybe try another switch to see if I been sold a dud one?
 

·
Premium Member
Joined
·
2,624 Posts
A continuity test just tells you the contacts are closed, it doesn't tell you at what pressure they open to put the light out.
The only sure way to do that requires a regulated air supply test set up.
When you changed the oil, did you change the filter?
 

·
Registered
Joined
·
49 Posts
you need to check continuity from the plug on the oil pressure switch back to the plug on the ecu, most likely a poor connection at the plug
 

·
Premium Member
Joined
·
14,650 Posts
What do you need to know/test, i dont fancy listing the whole pinout for a few wires.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #11
What do you need to know/test, i dont fancy listing the whole pinout for a few wires.
It's for the oil pressure switch. Need to find out if it's earthing out somewhere or cross connecting. Thank you
 

·
Premium Member
Joined
·
14,650 Posts
Its the Blue/Yellow wire at Pin 5 in the front ecu plug, thats the one closest to the front of the car.
 
1 - 12 of 12 Posts
Top