Vauxhall Owners Network Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi guys, Im new to Vx/Omegas/and this forum, so hi to all of you lot and hope you can help me?

I have a couple of issues with my 2001 (Y) Omega - 2.2 cd!!

Its only done 39,500 and with FSH, but when starting up from cold the top end rattles/taps quite loudly for about a minute or so. It does disappear when driven for a mile or so, but it doesnt do it when the engine is hot.
It is due for a oil change very soon, so could it be the wrong grade of oil used in the first place? (too thick?) Im planning to put 5W/30 magnatec - would this be ok?

When the engine is idling for a short while the oil light comes on until the engine is revved - is this ok? or is this oil related too?

Thanks for any feedback:Cool2:
 

·
Premium Member
Joined
·
7,262 Posts
i would have the oil pressure checked pronto , same with an oil change , if the oil pressure is going low enough to put the oil light on at idle then it sounds like there is something wrong , even though it could be a faulty oil pressure switch but get it looked at rather than cause damage.
 

·
Registered
Joined
·
682 Posts
Hi guys, Im new to Vx/Omegas/and this forum, so hi to all of you lot and hope you can help me?

I have a couple of issues with my 2001 (Y) Omega - 2.2 cd!!

Its only done 39,500 and with FSH, but when starting up from cold the top end rattles/taps quite loudly for about a minute or so. It does disappear when driven for a mile or so, but it doesnt do it when the engine is hot.
It is due for a oil change very soon, so could it be the wrong grade of oil used in the first place? (too thick?) Im planning to put 5W/30 magnatec - would this be ok?

When the engine is idling for a short while the oil light comes on until the engine is revved - is this ok? or is this oil related too?

Thanks for any feedback:Cool2:
The recomendation for oil on this forum for Omegas is Vx Semi Synth, or Vx Fully Synth, or Mobil equivalent, (10/40 grade).

I would try an oil and filter change first because if the oil/filter are dirty, they can give a false oil pressure reading.

At 40K I wouldn't have thought you would have oil pressure problems.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
cheers guys for the info :bananasmi

Done an oil change and everything is much better now, although the tapping noise isnt anything to do with the tappets.
One of the exhaust manifold bolts has sheared off (apparently common on these engines esp in the vectras) and this causes the noises.

Ah well, its still under warrenty so its off to the garage next week;)
 
1 - 4 of 4 Posts
Top