Vauxhall Owners Network Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Good morning all
I have been given an 03 plate Zafira club, reason it was given is the ignition switch was broken and the previou owner just wanted to scrap it, so I took it as a project, I replaced the ingition barrell as there was no spring return when you went to position 3 on the old switch, on inspection of the old barrell I noticed that the long pin had the last maybe 1/4 missing, so I removed the other side of the ignition switch and found the missing part sitting in the female part of the electrical switch which I also replaced, I had a new key cut to match the Zafira fob, removed the little bit which looks like a piece of slate from the old key and put it in the new key,as I had read that this was something to do with the imobiliser, on assembly and test I have no ignition lights, starter turns ok, would someone be kind enough to tell me what I have done wrong, or steer me in the right direction.
 

·
Premium Member
Joined
·
618 Posts
Check your wiring connection first to the ignition switch, the ignition switch you replaced was it new aftermarket part or used, I've had issues with cheap ign switches, my ignition barrel snapped on mine I thought I'd replace the switch and it would it wouldn't start unless I really twisted the key so switched over to the old switch and it was fine, I did later strip the old switch and greased up the runners which go dry and stiff and cause the barrel tip that goes into the switch to snap off.

That grey slate bit is the immobiliser chip.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Check your wiring connection first to the ignition switch, the ignition switch you replaced was it new aftermarket part or used, I've had issues with cheap ign switches, my ignition barrel snapped on mine I thought I'd replace the switch and it would it wouldn't start unless I really twisted the key so switched over to the old switch and it was fine, I did later strip the old switch and greased up the runners which go dry and stiff and cause the barrel tip that goes into the switch to snap off.

That grey slate bit is the immobiliser chip.
Hiya, thanks for the reply, all parts I replaced were aftermarket, will check at the weekend, also going to check the fuses relating to the ignition system. thanks again
 
1 - 3 of 3 Posts
Top