Vauxhall Owners Network Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
56 Posts
Discussion Starter #1
hi all, ive just found this forum and what ive read so far is pretty imppressive so i have a 2.0 16v ecotec n reg cavvy she drives well but i have a couple of probs which i hope someone can help me out if poss? no 1 the engine management light flashes and i cant start the car this happens only on the odd accasion . no 2 the engine sounds rattly when first started in the morning but seems to cut out on me until it warms up but also when i return to the car it seems to go above 1000 revs but not to much. please can anyone help shed some light onto it for me?
 

·
.
Joined
·
22,199 Posts
roger32 said:
hi all, ive just found this forum and what ive read so far is pretty imppressive so i have a 2.0 16v ecotec n reg cavvy she drives well but i have a couple of probs which i hope someone can help me out if poss? no 1 the engine management light flashes and i cant start the car this happens only on the odd accasion . no 2 the engine sounds rattly when first started in the morning but seems to cut out on me until it warms up but also when i return to the car it seems to go above 1000 revs but not to much. please can anyone help shed some light onto it for me?
Firstly welcome to the site Roger :)

The flashing EML and failing to start is an immobiliser fault, although intermittant as you describe, it still needs investigating as it may become permanent one day.

The rattly engine in a morning will more than likely be the hydraulic valve lifters, or one of them...they have a habit of draining of oil when the engine is stood and the rattle is while they are re-filling with oil...very common with 16v engines of our age.

I have no idea on the cutting out when cold...and the 1000rpm+ idling will more than likely be while the secondary air injection pump is running...IIRC they all do it, and settle back to normal idle after it shuts down.

I hope that helps slightly :)
 
1 - 3 of 3 Posts
Top