Vauxhall Owners Network Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
Hi guys i had a MOT and service about 3 months ago all good passed no worries but now the service soon light comes on every time i start it, ive been told this can indicate an issue. there are no running issues and ive checked all regular thinks i can see coolant was a bit low which im now topping up but dont think would put service light on isnt there a coolant low light? would this be the case of OBD check?
 

·
Worn Out Member
Joined
·
8,423 Posts
It indicates there is an issue and there will be a fault code logged,
an obd2 reader may not be good enough though as they generally don't pull manufacturer specific codes.
 
  • Like
Reactions: Boroboy

·
Registered
Joined
·
19 Posts
Discussion Starter · #3 ·
So it’s a garage job ? I’m hearing standard issues for this is
Glow plugs but some have sensors that make it a lot more expensive. How would I know if mine had sensor or standard ?
 

·
Well-known member
Joined
·
16,186 Posts
They look completely different, a Google image search will show the difference.
 

·
Premium Member
Joined
·
3,518 Posts
I’ll try and take a look myself before giving it
In
You are best off taking it in for a diagnostic rather than spending money on guesswork.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #8 ·
So I have ran a check it say glow plug cylinder 2 malfunction. Next question is are they sensor or normal (hoping normal) on the pics I’ve uploaded
Automotive tire Bumper Cylinder Gas Motor vehicle
Automotive tire Motor vehicle Hood Automotive design Automotive exterior
 
1 - 8 of 8 Posts
Top