Vauxhall Owners Network Forum banner

1 - 20 of 20 Posts

·
Astravan 1.9cdti sportive se 185bhp
Joined
·
6 Posts
Discussion Starter #1
hi.

i have an astravan 2010 z19dth.

fuel pressure is running at 1800 bar, leak back test done on injectors, new pump regulator, filter, fuel sensor and injector return chamber. vehicle starts every time idles for 30 seconds then idles really rough with a knocking sound. if you rev it a bit it sounds a bit better. engine in limp mode. you can hear the fuel returning to the tank.
if anyone has any ideas would really appreciate it. original fault code was 0001 high pressure pump, since changing regulator fault has gone. can only assume what ever the issue is damaged the regulator.

cheers

darren
 

·
Astravan 1.9cdti sportive se 185bhp
Joined
·
6 Posts
Discussion Starter #5
Hi Andy.

For some reason my opcom won't communicate with engine ecu. It's says timed out can't connect to ecu.

Was told because it's been remapped, but I don't believe it.

All I know his mechanic put snap on tools on it and had a fuel pressure reading of 1800 bar.
The return pipe from injector's was leaking fuel at the tee section and where it goes onto return chamber.



Dal.
 

·
Premium Member
Joined
·
15,101 Posts
If your van has a remap it wont stop Opcom from connecting, i have problems with mine and usually move the interface slightly which helps it make a better connection at the obd port.
If thats at idle then its way to high as you know, have you checked the return line running back to the tank for any sign of a crushed pipe, i have also seen it where the small section of return pipe in the intank module has become blocked.
I suppose you could always try running it with the return pipe fed to a separate tank/fuel can to rule out the return line blockage theory.
 

·
Astravan 1.9cdti sportive se 185bhp
Joined
·
6 Posts
Discussion Starter #7
Hi Andy.

I will have a look tomorrow regarding return pipe and give opcom another go. When mine tries to connect to ecu it make car with spanner flash on and off.


Dal
 

·
Astravan 1.9cdti sportive se 185bhp
Joined
·
6 Posts
Discussion Starter #9
ok. ecu been checked all ok. injectors been swapped still doing the same thing. all thats left is in tank fuel pump. coukd this possibly have a fault on it causing it to over fuel the system.

dal..
 

·
Registered
Joined
·
3 Posts
Hi i also have a problem with my Opel astr 1.9 Gtc it has high fuel pressure i can figure it out
 

·
Worn Out Member
Joined
·
7,066 Posts
1800 bar on idle is way to high
but we don't yet know the pressure,that figure was from a different poster a couple of years back,
i do wish people wouldn't add to old threads,it just confuses things.
 

·
Premium Member
Joined
·
15,101 Posts
Then it’s way to high. Check the return lines not blocked first. Has any other work been done on it.
 

·
Premium Member
Joined
·
15,101 Posts
No he needs to check the fuel return is not blocked,.. im surprised it even idles at that pressure, what you using to read the live data and what fault codes do you have.
 

·
Registered
Joined
·
34 Posts
Just solved low fuel press problem in my z19dth. Fuel connection above the hp pump that Tees off to the hp pump and the return from top of injectors.. From what I've learnt here is that it's a non return valve for the injectors, which in my case has failed and this came from a scrap yard so probably why the car was scrapped..
Caused codes rail pressure low and limp mode. Blocked the pipe and routed injector returns to a bottle and it drives 100%.

In your case might be worthwhile remove the return pipe at the tee from top of injectors and turn on your key and if you have fuel heading for the injectors there's your problem
 
1 - 20 of 20 Posts
Top