Vauxhall Owners Network Forum banner
1 - 20 of 24 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Hiya, I'm new to the site so hey everyone!
I bought a 2010 vauxhall insignia 2.0 cdti recently, starting to wish I hadn't!

So engine management light has been on (however when I bought it I presumed it was the service light) but now it has started making this noise when idling. Any ideas?
 

·
Well-known member
Joined
·
17,862 Posts
The 2.0 engine suffers from low oil pressure when the oil pick up seal hardens and then fails to seal adequately.
Usual symptoms are the oil pressure light takes longer than normal to go out.
What follows if the problem is not rectified is a rapid death as the main crank bearings run dry.
So people either fix it or flog it on to some unsuspecting buyer.
Typically this can start to be an issue from around 80,000 onwards.
 

·
Well-known member
Joined
·
17,862 Posts
But does the oil pressure light come on with just the ignition on, engine stopped? 🤔
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #5 ·
Not that I've seen. I've had it on home diagnostic and got this from the engine ecu if there's anything on this? I know the dpf needs cleaning, that's another issue I've seen
Font Material property Screenshot Number Rectangle
 

·
Premium Member
Joined
·
4,171 Posts
As said above, when the ignition is turned on but before the engine is started, the oil pressure light should come on.
If it isn't coming on, then either someone has disconnected the pressure switch, the pressure switch is faulty, or, someone has taped over the light in the dash (or there is a wiring fault).
In any case, you need to get it sorted, but, judging from the noise in your video, it doesn't sound good.
How long have you had the car, and was it a private sale or from a dealer?
If you bought from a dealer, take it back.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #8 ·
Yeah the oil can lights up when ignition is turned on then goes off after its started.

Just started the engine, to start with no noise, it then starts after about 10 seconds. Disappears when Accelerator is put down but comes back at idling revs
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #11 ·
Sorry lol been a long day stressing about the car.
Its booked in at the dealership anyway next week.
Should it be something that would picked up on a vhc? Or a service?
 

·
Well-known member
Joined
·
17,862 Posts
Sounds like it's knackered to me.

I wouldn't expect a service to pick it up but I would expect a potential buyer to notice it on a test drive, or take along someone with them who knows what to listen for, or even to pay for something like an RAC inspection.

Don't drive it like that.

If it is a failed oil seal that needs sorting but not before the main bearings and big end bearings are all checked, which will not be cheap.

You might be lucky to get away with new bearing shells but it does sound really bad.
 

·
Well-known member
Joined
·
17,862 Posts
Of course we could be completely wrong and an oil pressure check using a gauge should be part of the diagnostic process.
 
  • Like
Reactions: Alan G H

·
Premium Member
Joined
·
4,171 Posts
As said by Koi above, it needs an oil pressure check. If it was me, I would not drive it until it's been checked & diagnosed.
 

·
Well-known member
Joined
·
17,862 Posts
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #18 ·
Thanks everyone, when I went to view everything was fine. Test drove it no issues, did take someone with me but again with it being fine was no concern.

I've had it a week, and in that time I've had it serviced by vauxhall and the vehicle health check. Drove back from vauxhall fine, started up yesterday and started making that noise.

What rights do I have to take the car back as it was a private sale. Only positive thing is the receipt didn't state sold as seen.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #19 ·
So, just had a mechanic come have a look, started engine up, started making the noise. He told me put the clutch down, did that noise stopped. Even at idling. Said its more than likely the dual mass flywheel wobbling..... that sound about right?
 

·
Premium Member
Joined
·
4,171 Posts
If that stops the noise, then there is a good chance that's the problem.
However, I think I would still get the oil pressure checked.
 
1 - 20 of 24 Posts
Top