Vauxhall Owners Network Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
I have recently purchased a 1998 2.0i ls diesel vectra estate. (73,000 miles)
The car was seemingly running well until a few days ago. Started it up drove a few hundred yards and was stopped at the lights. When I tried to pull away the Engine Management light came on and the car lost all power. Managed to get home in (limp mode) .. would not go over 1800 revs.

Called out the AA but when he connected his computer he could not read it. When he disconnected it the car turned over but would not start. Apparently he said that connecting his computer had caused this, he disconnected the battery for a couple of mins. and the car now starts but I stll have the EMU light permanently on and the car is virtually undrivable in limp mode.

I have looked through the threads and have seen conflicting advice with redards to the paper clip method working or not with diesels. Mine is located behind gear stick but the only used pins are 3,4,5,7,8,12 and 16.
This obviously means I can not connect 6and 5 or 6 and 4 as stated.

Can anyone help as I do not want to have to pay £75 quoted by local vauxhall dealers just to plug their computer on. I did get a local auto electrics to plug a universal computer into it but it would not connect properly for them to read any fault codes etc.

By way of a possible lead up to the fault I had noticed the EML coming on from time to time usually at low revs / speed for a few seconds and then going off when accelerating but did not think much of it as it did not seem to be effecting the car in any way.


Thanks in advance for any help.

Further to the above. I have now been advised by a different garage who managed to connect their computer that the fault is code 1220. After trying the easy things first the fault finding eventually resulted in a valve in the fuel pump which needs replacing.

Bloody marvelous - only had it 3 weeks and no warranty as it was a private sale!!!!!

Does anyone have any advice re- probable costs and or if I should buy a new one / or should I have the valve replaced or the whole unit reconditioned.

thanks in advance
 
R

·
Guest
Joined
·
0 Posts
the Di tanks/faults/bhp???

iv heard allot about this limp mode and my service history gives me reason to belive mine has gone thru this at some point made me laff when previous owner decribe`d it, anyway sorry.
Are there any signs to look out for just before this fault began (like maybe warning lights staying on a bit too long, the temp and/or anything else whatsoever maybe even fuel use/noises and rattles) it seams the di is a dire model to own by the look of things, allbeit with a solid as £^$& chassie, and is it just me or was some1 takeing the piss when they said 83BHP?? what about torch if theres any1 whos knows theres things
 

·
Registered
Joined
·
32 Posts
Discussion Starter #3
guys,

After reaing these forums I have seen a lot of useful and practical advice.
Thanks to those who have contributed as such.

To those who have not... work it out.....thanks for nothing metric 321, not quite sure what you thought you were adding to the post !!!!!

To any one else serious comments / advice much appreciated.

Thanks in advance.
 

·
Registered
Joined
·
5 Posts
I'm afraid I know next to nothing about diesels but the Tech2 charge from your Vx dealer seems a bit excessive. However,you could end up chasing your tail looking for faults without the tech2..so my advice would be to bite the bullet and have it done. At least you will have a Vx technician to interogate to get his opinion of what the fault maybe.

I have heard...and I don't know how true this is...that if the engine oil is low on a diesel the EM light can come on momenterily at low revs/speed...so as daft as it sounds maybe check your oil level.

On the petrol models limp mode is commonly put down to crankshaft sensor or camshaft sensor faults...try doing a search and see if you can find anything.

Best of luck and hope you get it sorted.
 
R

·
Guest
Joined
·
0 Posts
garyjwilson said:
guys,

After reaing these forums I have seen a lot of useful and practical advice.
Thanks to those who have contributed as such.

To those who have not... work it out.....thanks for nothing metric 321, not quite sure what you thought you were adding to the post !!!!!

To any one else serious comments / advice much appreciated.

Thanks in advance.
i spoke to the previous owner today (a family member) he told me what it was, but im sure you`ll ... work it out ...
 

·
Premium Member
Joined
·
401 Posts
The Di/DTi Vectra-B's don't have pin-6 wired on the diagnostic connector so they won't paperclip test etc. - you need a Tech2 code readout at a garage, unfortunately. You don't have to spend £75 at a Vx garage to have this done, try an independent.
 

·
Registered
Joined
·
3 Posts
My 1998 DTi Vectra has started showing an intermittent EM light, with no apparent effect on performance. Local garage got a sparky in to diagnose and has been trying for weeks to get info from Vx on what to do next.

I have seen the fault codes posted here but am a bit confused. Have had compnay car for ~20 years and when I last maintained cars they did not have this stuff. Several fault codes seem to have multiple descriptions. How do I know which is the right one?

Sorry if this seems a bit basic. Got a lot of catching up to do.

Thanks
 
1 - 7 of 7 Posts
Top