Vauxhall Owners Network Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi all, I have a problem with the heater in my car. The air only gets tepid inside, just enough to keep the windows clear.
If I'm on the motorway, it'll get luke warm, but not enough to make the car warm inside, I still need a coat & 2 pairs of socks.

When ticking over, or normal running around, if I switch it on, it'll be luke warm for a few seconds, then go cold again.

My brother said it might need the heater coil flushed. We pumped out the fluid and it was very dirty, so we filled it with clean water & anti-freeze, but
I just noticed that actually the fan only works once it's switched all the way to No4. No1, 2 & 3 do nothing, so maybe it's the switch?

It also has a problem going into icey road mode every now and again, so maybe they're related?

Thanks
 

·
Premium Member
Joined
·
593 Posts
And is your engine getting up to temp if it is it's probably a resistor if it's not it's probably thermostat
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Thanks for the replies.

I just went out and had a tinker.
I popped the bonnet and both pipes are hot, water is hot in the reservoir.

It's getting warmer only at high 3000+ revs. When I go back to idling, it goes cold again. If I switch the fan off for a minute, then switch it back on (whilst idling), I get warm air for a few seconds, then cold again.

Temperature guage is staying at 11 o'clock at high or low revs, so I guess that rules out the thermostat.

When I move the switch from cold to hot, I can hear the valve shutting off and the change in the tone.

Baffled..
 
1 - 4 of 4 Posts
Top