Vauxhall Owners Network Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hi all,
More problems with my 2011 1.8 zafira b!
One of my side lights wasn’t working so changed the bulb then both didnt want to work... checked with multimeter no power getting to them.
After messing around checking wires with multimeter I eventually had the lightbulb go one in my head and realised it must be a problem with the switch unit... no fuse / relay to check (That I can find)
Here’s where it gets really weird I took switch unit off to check the power was actually getting to the unit I checked each wire whilst using the earth wire on it and also using the door hinge as an earth and got no power from any of the wires (engine was running)
Very strange because when I reconnected it into back of switch the head lights and main beam worked ok.. therefore I believe switch is faulty.
BUT the running lights would not go off at all so disconnected battery overnight, today I reconnected battery , disconnected wiring from switch so could use the car without having to remove battery till I can get another switch.
When I turned engine on the headlights and running lights came on !
I find that weird because I would have thought that by disconnecting the lighting from switch unit then the power could not reach the lights or am I being thick?
What do I need to check now please😊
 

·
Well-known member
Joined
·
13,364 Posts
The switch doesn't turn the lights on, it just tells the UEC that you want the lights on,which then puts them on for you. So a CANBUS fault can cause the lights to be on, even with the switch disconnected.
 
  • Like
Reactions: Fred Bassett

·
Premium Member
Joined
·
2,354 Posts
The first thing I would try is cleaning the UEC. There is a thread on this site showing how to do it.
 
  • Like
Reactions: Fred Bassett

·
Registered
Joined
·
8 Posts
Discussion Starter #5
eventually got it cleaned .. but no better have checked for breaks etc in wiring under hood tomorrow going to dismantle inside dash board etc
But I do wonder if it’s something to do with the wiring that was changed a little while ago under the recall notice (Something to do with air con I was told)
Because in the last few days:
The rear heated window is now permanently on,
front electric windows have stopped working( closed them by applying power direct to switch circuit board so it’s obviously a wiring problem),
And the air con decided it wanted to push out hot air instead!!
As I don’t know which wires were in the harness they changed
I’m just wondering if it could be the problem or not
I’m aware that air con might need re gassing ( even though I was under the impression that it should never need re gassing unless there is a leak in the system
 

·
Premium Member
Joined
·
2,354 Posts
Did you actually take the UEC out, and clean the wring connectors underneath?
The ones I've had problems with have had problems there, rather than within the UEC.
It might be worth checking the electrical centre in the back for water ingress as well, as that controls some things at the front as well.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
Did you actually take the UEC out, and clean the wring connectors underneath?
The ones I've had problems with have had problems there, rather than within the UEC.
It might be worth checking the electrical centre in the back for water ingress as well, as that controls some things at the front as well.
Hi yes I took it out cleaned it with electrical spray and I also checked the back bit where the 50 amp fuses are, incidentally there was no water ingress I also took the 2 leads on the Ecu off took Ecu off too and sprayed them too to no avail
 

·
Super Moderator
Joined
·
26,655 Posts
Hi yes I took it out cleaned it with electrical spray and I also checked the back bit where the 50 amp fuses are, incidentally there was no water ingress I also took the 2 leads on the Ecu off took Ecu off too and sprayed them too to no avail
They don’t always have moisture in , mine was bone dry. However by removing it & putting it back together it cured my throttle fault.
Did all this start straight after the recall work ?
 
  • Like
Reactions: Alan G H

·
Registered
Joined
·
8 Posts
Discussion Starter #9
Pretty much .they told me one of side lights wasn’t working then when I tried it it did but then all my lights didn’t come on / go off as they should with the the switch ( that’s why I originally thought It was the switch, the the door windows stopped working and the heated rear window stayed on, then lastly on Friday the air con started putting out hot air— but on Saturday it was chucking out cold again!!
Thats the reason I think it’s something to do with it but as I don’t know what they did/ touched on the recall I was trying to find out what wiring loom they might have touched/ changed and what the wires were connected too other than the air con
 
1 - 9 of 9 Posts
Top