Vauxhall Owners Network Forum banner

1 - 4 of 4 Posts

·
Premium Member
Joined
·
425 Posts
Discussion Starter #1
Zafira B - z19dth euro 3 non dpf

Hi All,

So for 3 years my thermostat has been broken and stuck open. I’ve tolerated it and just couldn’t be bothered, because obviously it’s better than being stuck closed.

So in addition to that, I’ve had an intermittent 2279 air intake leak. If I was stationary for periods (in traffic) it would come on shortly afterwards of normal driving. I had a welded inlet and some of the welds are leaking so it also was on my todo list, but I almost managed to work out how far I could push it in effect, and along with Torque app I got by. I wasn’t sure if the inlet was the full cause or one of the rubber L pieces I broke when checking the lines to the boost solenoid. I used a bit of silicon and wedged the pipe in that and connected it back up.

So a few days ago I finally got around to doing the thermostat with hemp from my mate - oh the joys of heat in the car and it finally getting up to temp. However this has caused an issue. When it gets up to temp now even if I haven’t been stationary the lovely 2279 comes on now usually bang on 85-88c.

I’m assuming that cuz the engine temp is right it detects it better now. I’ve purchased some 3mm silicon hose and I’m going to run new lines from vac pump to solenoid and then another to the turbo - as that’s a cheap start and I’m hoping the cars more bothered about the silicon bodge rather than the inlet. Apart from that what other things can I do before the inlet (which someone is gonna do in jan I think for me)

Thanks
 

·
Premium Member
Joined
·
425 Posts
Discussion Starter #2
So had another inlet fitted today. What a mess my old one was. The guy who fitted it previously didn’t put bolts back screws for the vapour chamber, he didn’t put my gasket back on the throttle body to inlet. Etc

Well new one on and looks perfect - still unfortunately getting air intake leak as soon as car gets to 82-88. I did decide to remove my blanking plate off the egr now to see - still the same and the egr has been tested and working.

Running out of ideas. When I rev hard and let it go it does sorta dump a little air. The solenoid/boost sensor have been changed previously (front drivers and rear of engine).

Any other ideas where to check guys? I’m fairly sure though the code is now 2279-11 and not 56.
 

·
Premium Member
Joined
·
3,589 Posts
This seems to happen when I take my car to get fixed in three-quarters of the garage in Gainsborough, they will sort of fix one problem and while we are at it loosen that and bend that a bit, and we might get the job of fixing it again, I DON'T THINK, I am not an old lady that believes every word they say.
 
1 - 4 of 4 Posts
Top