Vauxhall Owners Network Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
ive got a cavalier sri.. its a L REG, its been parked up for over a year now.. the other day i try starting it.. nothing happend. so i jump started the car with another battery and the car started up first time.. but when i truen my car off the battery goes deaD. the electrolyte levle was low on the battery, is my alternator faulty? or my battery? is there a way i can check if my alternator is faulty?

also when my cars on water steam comes into my car through my vents?
whats that mean.
 

·
8v Power!
Joined
·
10,748 Posts
Well, if its stood for a year, your going to have to run it a while to get the battery charging.

Failing that, might be a faulty earth. was it a known good battery?

Also, do a full fluid change on that car.. year old oil isn't going to be too nice and the coolant won't be much better.

Good Luck.
 

·
8v Power!
Joined
·
10,748 Posts
I doubt it, change your fluids and jump the car. run it for an hour or so - then check the charge on the battery.

If its charging your fine. But you should notice a change in voltage as soon as the car is running and the alternator is turning.

Um, another thing to try is disconnect the battery, remove the earth lead from the body shell and clean up the contact area. and do the same for the battery end too. then try again.

good luck mate.
 

·
VxOn's Nissan Advocate
Joined
·
1,324 Posts
check the voltage accross the alternator at adle and at rev, at idle it should be a contant 12v give or take, and at rev it could rise to as high as 13. if it fluctuates all over the place the alternator is fooked.
 

·
Premium Member
Joined
·
1,379 Posts
The steam is probably coming from a blocked scuttle drain - check the flat hose that hangs down over the centre of your steering rack isn't full of compost!
 
1 - 7 of 7 Posts
Top