Vauxhall Owners Network Forum banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi all,

New to the site so nice to meet you all.

I've bought a 2010 Astra SRI 1.4t a few weeks back but it's developed a fault but thought I'd ask for some advice!

Car drives fine but occasionally drops power when pulling off, say from a roundabout, like all the power drains out of it then suddenly resurges and drives back as normal.

Idle is fine but when left standing it gets rougher and rougher until it almost seems to stall out but then recovers.

Engine light has come on but can't see anything else wrong.

I believe it's a coil pack problem but I just thought I'd see if anyone else has had the same issue or any other suggestions?
 

·
Premium Member
Joined
·
14,660 Posts
Hi all,

New to the site so nice to meet you all.

I've bought a 2010 Astra SRI 1.4t a few weeks back but it's developed a fault but thought I'd ask for some advice!

Car drives fine but occasionally drops power when pulling off, say from a roundabout, like all the power drains out of it then suddenly resurges and drives back as normal.

Idle is fine but when left standing it gets rougher and rougher until it almost seems to stall out but then recovers.

Engine light has come on but can't see anything else wrong.

I believe it's a coil pack problem but I just thought I'd see if anyone else has had the same issue or any other suggestions?
Sounds like possible coil pack or plug related. Best to have the codes read first with a decent diagnostic reader to try and pinpoint the fault.
Opcom good for diy diagnostics.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thanks for that.

Just got the codes read and it doesn't point to coil pack.

Can't remember the list but I'll post them when I can find them but essentially it seems like airflow is wrong and fuel is lean somewhere and now I'm thinking it's more like a split pipe somewhere but can't seem to find it?

Had this problem with a previous car. . . Anyone had this problem?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Fault codes are. . .

P0106: MAP sensor
P0131: Oxygen-sensor heater 1
P0171: Fuel trim, too lean
P1101: Intake Air Flow System

If that helps!
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top