Vauxhall Owners Network Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
610 Posts
Discussion Starter #1
Well something is wrong with my little car a J reg ford escort 1.3, I think there is a problem as opposed to many, it all went wrong just as I was turning into my drive this morning

List of Problems: 1) Rev counter does not work, I noticed it was at zero revs yet the car was still running, as I accelerate the revs rise to around 900, no matter if the true revs are higher it just stayed on 900 or 0, then when I lift off it goes back to zero, anyway I started the car again to further invertigate and touched the accelerator and the rev counter rised and kept on rising, it is now sitting off the scale at about 8K revs, the scale ends at 7 :rolleyes:

2) Then I began to notice further problems, the car temp gauge doesnt work and is at the bottom, like the car isnt even on

3) The battery light is on constantly when the car is running, the manual choke (yes its that old :p ) and parking brake lights are on too just very dim, when I hit the brake pedel the battery light gets brighter, and the two other dashboard lights that are on disapear, when I lift off brake the battery light dims and the two other lights return

4) I only have sidelights available, main headlights and main beam do not come on, nor can I pull the stick back and flash the headlights when I move the indicator stork for them or push it forward for main beam just the sidelights (dipped main beam or what ever you call them) stay on

5) When playing a tape in the car it will sometimes stop playing sound from the 2 right speakers, but when you switch to radio all 4 work again

Please help me, with no main headlights I cant drive at night :cry: The car was fine yesterday with none of these problems and I believe it to be mechanically sound, I think I might of heard a click as I was coming into the drive but whether it has anything to do with it or not who knows :S

Where should I even start investigating the problems? Take the part of dash out that has the rev counter, speed counter, fuel level and temp and the warning lights out and see if there are any loose wires? why would this affect the headlights though, maybe its the stork? arrh help :)
 

·
Premium Member
Joined
·
2,998 Posts
I would have said the column switch if it was just the lights playing up but with the rest of the faults as well i'd be looking towards the fuse box as they are well known for playing up (tracks burn out inside) or maybee waters got in.Could also be a wiring/earth fault to mind due to the number of faults that all came at once.
 

·
8v Power!
Joined
·
10,748 Posts
that or possible alternator failure. but i'd leantowards wiring first.
 

·
Registered
Joined
·
610 Posts
Discussion Starter #4
So what do I do, call some guy out to test the wiring? Could end up costing more than the car is worth :rolleyes:
 

·
Another Dead CDX
Joined
·
767 Posts
check battery leads,

disconnect alty then start car and see if problem still exists

could be small wire going to pos on battery

take off cover surrounding bottom of dash drivers side and drop fuse box down, check all relays on top of fuse box and all main connections..

Also remove all neg - connections to battery and clean then replace.

check as many neg - conections as you can even the ones near the rear lamps on the back panel .

Check earth lead from car body to bonnet.

definatley earth connctions somewhere..

MD

If you get stuck e-mail me i only live in sale a few miles away...
 

·
Registered
Joined
·
610 Posts
Discussion Starter #7
A fuse had blown that was for the rear lights, crazy why it effected all the other things too, but seems fixed now unless it blows again, thanks for all the help guys

:D
 
1 - 7 of 7 Posts
Top