Vauxhall Owners Network Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I have a K reg Vauxhall Cavalier 2.0. I was fitting a new stereo yesterday and think I may have caused a short. The battery warning light is now constantly illuminated, the RPM needle does move, the fuel gauge does move and the temp gauge doesnt move. The speedo works fine.
Any advice would be appreciated.
P.S. i have now disconnected all of the steros wires.
 

·
Premium Member
Joined
·
7,262 Posts
you have blown the fuse for the ignition feed on the radio , this fuse also powers the dash clocks & *** lighter.
 

·
Registered
Joined
·
11 Posts
sorry to bring an old topic up, but i have the same problem, just done exacltly what darbyxsc has done new radio, but i have the 1.8i version l reg, difference being the fuel guage dont work either on it, and the fuse you are talking about, is it in the fuse box by the drivers knee? as i have checked them and all seam alright, they did work to start off with tho, the radio was working so was the instrument clocks, then dad stepped in to go somwhere and problem, i know the alternator is charging thank god, as i have a muli meter. and i will have a go tomorro, could you locatet me to the correct fuse please

thanks in advance
 

·
Premium Member
Joined
·
31,467 Posts
Yes, fuse box is behind the pull down flap by the drivers knee.

Check fuse number 2, should be a 20A fuse. That's whats' listed in the Cavalier owners manual anyway for the cigarette lighter, with the Radio being on fuse 20 which is a 10A fuse, and intrument illumination being on fuse 9, also a 10A fuse.

Welcome to VxON btw.
 

·
Registered
Joined
·
11 Posts
thanks for the quick reply, great site this, so i think what i have done is earthed the ign live wire and it has knocked the instruments out, knew i should have put new electrical tape around it, do u know whitch wire is ign live? if u dont worry as im sure i will figgure it out tomorro, thanks for the welcome

its ok, i found a thread that should help me out fine, thanks for the help lets hope this works
 

·
Premium Member
Joined
·
31,467 Posts
Have a good look around the forums, there's a wealth of valuable info at hand, all the info you could want is right here, as you can imagine, many members have been in your situation at some point relating to your question.

Enjoy.:)
 

·
Registered
Joined
·
11 Posts
thanks, i know what i did now, i thought the black was neg, and red was pos, and couldent figgure out why there was no ign pos

so figgured out from that brillant thread, tells you what the wire colours do what

so brown = neg
red = pos
black = ign pos

my pob was when ign was off (thats how i did it) the black becomes a neg but with ign on it becmes +, as i couldent understand why the radio kept going off with the ign on.

but thanks and some good info here, but all is ok at the mo.

stefan
 
1 - 9 of 9 Posts
Top