Vauxhall Owners Network Forum banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
FAULT CODES given out from holding pedals dowm and counting icon flashes:

1120
1122
1550
0230
0300
0141


ENGINE ONLY PLAYS UP ONCE WARM.

PROBLEM STARTED WHEN I HAD A STUCK THERMOSTAT, AND ENGINE HAD OVERHEATING ISSUES UNTIL THERMOSTAT WAS REPLACED.

I HAVE TO PROVIDE EARTH TO FUEL PUMP RELAY DIRECTLY FROM BATTERY FOR IT TO WORK WHEN ENGINE IS WARM.

feels like the throttle sensor is continually going on and off, it barely drives.

MOT almost expired now, so I Paid a garage £50 to have diagnosis made, and their conclusion was a new engine needed if car is kept, main reason was due to finding oil on 2 of the spark plugs.

had reconditioned engine (50,000 miles old apparently) fitted only 18 months ago, and I know there has always been a problem with having to clean spark plugs every so often due to oil build up on one of them, however found this quite manageable until the engine problem currently.

ANY THOUGHTS GREATLY APPRECIATED.
 

·
Premium Member
Joined
·
14,645 Posts
The earth for the fuel pump relay is normally supplied by the ECU so if its missing and the wiring is good then the ECU is faulty without looking at any other codes.
 

·
Premium Member
Joined
·
11,576 Posts
P1120 Throttle position sensor out of range
P1122 Throttle Position (TP) Sensor Circuit Intermittent Low Voltage
P1550 PSPS Out Of Self Test Range
P0230 Fuel Pump Primary Circuit Malfunction
P0300 Random/Multiple Cylinder Misfire Detected
P0141 O2 Sensor Heater Circuit Malfunction (Bank 1 Sensor 2)

Oil build up on a spark plug could be anything as simple as a valve stem oil seal, to a more serious piston rings.
 

·
I refuse to grow up.
Joined
·
16,082 Posts
Agree with AndyL DTC P0230 is usually the ECU giving up.
Oh and nearly forgot, very common on the 8 valve engine.
 

·
Premium Member
Joined
·
16,258 Posts
Same here. These set of codes are always down to failed ecu on the z14xe, z16se, z16xe and z18xe engines.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
P1120 Throttle position sensor out of range
P1122 Throttle Position (TP) Sensor Circuit Intermittent Low Voltage
P1550 PSPS Out Of Self Test Range
P0230 Fuel Pump Primary Circuit Malfunction
P0300 Random/Multiple Cylinder Misfire Detected
P0141 O2 Sensor Heater Circuit Malfunction (Bank 1 Sensor 2)

Oil build up on a spark plug could be anything as simple as a valve stem oil seal, to a more serious piston rings.
thanks for that
FAULT CODES given out from holding pedals dowm and counting icon flashes:

1120
1122
1550
0230
0300
0141


ENGINE ONLY PLAYS UP ONCE WARM.

PROBLEM STARTED WHEN I HAD A STUCK THERMOSTAT, AND ENGINE HAD OVERHEATING ISSUES UNTIL THERMOSTAT WAS REPLACED.

I HAVE TO PROVIDE EARTH TO FUEL PUMP RELAY DIRECTLY FROM BATTERY FOR IT TO WORK WHEN ENGINE IS WARM.

feels like the throttle sensor is continually going on and off, it barely drives.

MOT almost expired now, so I Paid a garage £50 to have diagnosis made, and their conclusion was a new engine needed if car is kept, main reason was due to finding oil on 2 of the spark plugs.

had reconditioned engine (50,000 miles old apparently) fitted only 18 months ago, and I know there has always been a problem with having to clean spark plugs every so often due to oil build up on one of them, however found this quite manageable until the engine problem currently.

ANY THOUGHTS GREATLY APPRECIATED.
thanks everyone for your comments,
any thoughts on what would be the cheapest way forward pls?

whether to try getting ecu repaired or a second hand one and getting it progarmmed to the car,

thanks
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top