Vauxhall Owners Network Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Ive got an x reg corsa comfort 1.2 (i think that makes it a corsa c) and it keeps cutting out whilst in neutral or with the clutch in (mostly happens at traffic lights after its been running for 5 mins or so). When i try to restart it, it takes ages and eventually turns on and the rev counter will read 0 revs and the engine management light will be on. If i stop and restart, it goes back to normal but usually happens again soon after.

Also more resently the exhast emissions light has been on all the time and will sometimes replace the engine management light after a restart when it cuts out. It also sometimes starts with the rev counter reading zero + emissions light on.

And another thing thats happened resently was when i was driving it had no power at low revs ie was struggling up a hill in second, that i do in second every day and started jumping as if it was about to stall in third when i slowed down slightly! (this has only happened once tho)

Ive read around and it appears that this could be the crankshaft sensor and/or the lambda sensor. I know nothing about the inner workings of car so i could be very wrong.

Sorry for the long essay!
 

·
Premium Member
Joined
·
703 Posts
you really need to get the codes read mate, by the sounds of it it is a sensor but not sure which one? Get the codes read by a tech2 and that will tell you what is buggered. You could physically check each sensor and corresponding plug and see if they are both clean and not damaged.
Other than that, sorry.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top