Vauxhall Owners Network Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi

So I have my radio presets 1 through 9. Number 3 is KISS fm. However, when I press 3 it does nothing, when I press 4 or 9, then KISS fm comes on and it says its preset 3.

I have no idea why it has started doing this, I started the car up last night and it happened. This morning it was fine and then this afternoon its started again.

I literally know nothing about cars, so any help would be appreciated (especially if it's put simply)

Its a 2010 Corsa, with CD30 original stereo (it's basic, no aux or anything)
 

·
Registered
Joined
·
68 Posts
Have you tried disconnecting the power and re-connecting again (btw be careful when removing the leads from the battery as it can be quite dangerous - and if you don't know what your doing get someone to help you who does - oh and importantly remember that when removing the leads on the battery the car shell itself should be negative (in some cases it can be positive but most of the time it is negative) so don't go placing the positive lead onto anything metalic in the car with the negative still connected or else you'll see a nice blue flash! - or easier is if you can get behind the stereo unplug the power cables from the back and re-plug them back in after a few seconds.

It will forget all your presets and reset the radio back to how it was first set up so you'll need to re-enter everything but it might make the presets work again. Failing that you could look for a new car radio - I'm quite sure the C30's are only double din units so can be swapped for more advanced models quite cheaply - I swapped my Zafira's radio for a Philips which cost about £25 and included MP3, USB and DAB on it (and now I can listen to Absolute 80's!!!) - mine was only a single DIN unit but if you've got a double DIN you could even replace it with one with a built in sat nav.
 
1 - 3 of 3 Posts
Top