Vauxhall Owners Network Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter · #1 ·
;)hello guys hope all is well just looking for a bit off advise here my veccie c 1.8 03 plate has the car with spanner through it i did have an op com on it and tryed to clear it but to no avail the code was p1680 but it was the fan control switch number two circut but as the fan does operate ok i think it maybe something else any ideas i have also have the parking sensor light coming up as well the back ones do not work every time i put it in reverse the parking light sensor comes up on the box where the car with the spanner come up i did have water in the boot so i would like to no if the water could have damaged a module in the boot i think there is on next to the spare wheel on the back panel next to the bumper but its the one on the inside off the boot but level with the bumper but the car does run ok a bit sore on fuel but ok also when the car is running it never seems to eat up only when sitting for ten min it mite start reading on the temp gauge i still have hot air coming through so defo not the head gasket i was thinking thermostat all help would be welcome have a good day all vauxhall owners :cool:
 

·
Premium Member
Joined
·
769 Posts
On the fan - I don't have the full list of codes handy but is it the cooling fan or the heater fan that is giving the fault code? I'm not sure the cooling fan will give an error code.

OK - normally as you know, the cooling fans are off until the engine gets hot. If they are on when the engine is cool then something is wrong. If they stay on with the ignition off they will normally run until the radiator cools and the thermoswitch in the radiator turns off, or until they flatten your battery if they never turn off.

The thermostat in the engine stays closed until the engine block has warmed up. Then it opens once the engine is hot enough, and allows the coolant to flow out of the engine block through the radiator. The radiator will then start to warm up, from the bottom. Sooner or later the top of the radiator will feel almost as warm (or as hot) as the bottom.

Before you start the engine, check the coolant level in the expansion tank while the engine is cool or cold. There should be some coolant in the tank, about half full. If it's just a little amount in the bottom then it's empty. Top it up slowly to about half full, then see below on how to try to get rid of air locks, just in case you have one

If your engine temp is not rising to about 80 degrees within a few minutes, it can be that your thermostat is stuck open.

If your radiator is hot at the bottom and cool at the top it might be low coolant level or an air lock in one of the hoses or in the heater. Turn on your heater to full heat and rapidly squeeze and release your big top radiator hose hard and repeatedly to try to get rid of air locks. When there is only air in the hose it will feel empty, with no resistance. When it has water and air in it you will feel and hear it "slooshing" backwards and forwards through the hose as you squeeze. When there is resistance and no "slooshing" then it is full of water without air. The water will squirt into the expansion tank as you squeeze, and any air bubbles will also be expelled into the expansion tank.

If the fans start when the radiator is only warm, not hot, then it may be the thermoswitch in the radiator is faulty and is switching on at a low temperature. Carefully put your hand on the radiator near the switch to feel the temperature, it should really be just bearably hot to your hand before the fans come on. Remove the plug and the fans should stop.

Let us know what you find.
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #3 ·
Hello there the car runs fine it will only heat up when it is sitting ticking over and when u take it a journey the gauge goes down does not even read on the gauge. The fan does kick in about 90 so all is well there when the winter was there was not alot of heat coming out off the heater unless it was ticking over for a while then when u did take it a run it was just a wee bit hot
 
1 - 3 of 3 Posts
Top