Vauxhall Owners Network Forum banner

1 - 20 of 54 Posts

·
Premium Member
Joined
·
2,550 Posts
Discussion Starter #1
Ok so i finally picked up the Gsi on wednesday. ran fine all the way home even did 37mpg!
Clutch isnt that bad yet it just rides abit when changing gear when u put ur foot down.
Heres a few pics...







There is a few niggles with it,i took the dash out yesterday to change some bulbs and found that there was no ABS light :eh
Ive since found out that the speedo cuts out no and then and since i put in the ABS bulb its when that light up the speedo doesnt work so thats got to be connected somehow?! Any ideas anyone?
Also sometimes the key fob doesnt work....
Front ashtray is knackered...
Steering wheel looks tired....
Wheels need a refurb...
Rear bumper needs a respray...etc etc

Other than that,it just needs a bloody good clean and tidying up. Got stacks on receipts with it and it has a K+N panel filter a full jetex system,That V6 roar is very addictive lol!

I will get some better pics up when its had a polish on sunday.
 

·
Premium Member
Joined
·
13,088 Posts
whys it on an irish plate?you abs woes will be sensors or reluctor rings on the hubs
 

·
Premium Member
Joined
·
10,875 Posts
Looks tidy enough. The speedo uses the ABS sensors to work, get a decent Tech2 on it and it should tell you which sensor(s) are a bit dicky. They might just need a good clean.
 

·
Premium Member
Joined
·
10,875 Posts
spot on cheers mate. ill do that

Didnt know u were selling ur turbo?!

Should be pretty simple. Just out of interest, check the MOT database, you will see the history and it will tell you if it's failed on ABS recently.
Wasn't until this week... :-( It's a long story, I'm not impressed. Funnily enough, I'm looking to replace it with a Vectra GSi...
 

·
Premium Member
Joined
·
2,550 Posts
Discussion Starter #10
gutted for u mate if ur getting rid....

I will mate, to be fair he did tell me he'd had trouble with the speedo cutting out and had put new speed sensors on,even gave me a spare,and a spare set of clocks, seonsor looks an old one though. But still,ABS bulb was removed....

Another pain in the arse is i changed the bulb under the petrol and temp gauge and now its brighter than the othe side so ive got to do it all again! Piss take.
 

·
Premium Member
Joined
·
2,267 Posts
Looking tidy, mate. A pair of GSi/SRi tinted rear lights will make the rear view far more attractive. Like it, fella.
 

·
Premium Member
Joined
·
2,550 Posts
Discussion Starter #15
Cheers for the comments...
Done the oil today and 3 pipe mod. Also tried to wash the coke/coffee stains off the silver surround on the dash and cup holder's but it wont budge,ashtray as knackered and it has some deep scratches so i best just get a new set.

Also,when i done the 3 pipe mod i noticed it HASNT got a k+n panel filter in it! lying ******* told me it did. Just a new paper filter. May aswell get a cone filter for it now!
 

·
Premium Member
Joined
·
2,550 Posts
Discussion Starter #19
looking good


when u sorting the odd lights
As soon as a i find a decent set! Need to replace both because the n/s has a crack in it.
Replaced a front indicator earlier this week coz the clips were broke,the next day some arsehole hit the other side and cracked that in asda car park! Not pleased...

Anyway just gave the engine a quick wash down. Its not too bad considering i didnt use the jetwash!





Eventually i want the plenums done in red.
And yes it has still got the MSD sticker! Number 0241 :Cool2:

Jim
 
1 - 20 of 54 Posts
Top