Vauxhall Owners Network Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
i have 1.9 sri cdti vectra c on a 55 plate, prob i have is car was running perfect until 2 nights ago when the battery suddenly stopped charging and every ounce of power was drained by car till point it just cut out, replaced battery with brand new one thinking this was the problem but again car ran perfect for 10 miles till car drained battery again have checked every fuse in car and they all fine, been told to check alternator but not sure that alternator would have went from all to nothing in a heart beat, also few days ago started having probs with brake lights when i press the pedal they come on then go off after couple seconds, dash says fault with brake light switch but i have replaced that and problem persists.
does anyone possibly have any idea's or suggestions that might shed some light on my current nightmares, lol, thanks for reading..............
 

·
Premium Member
Joined
·
13,088 Posts
you need to find out what voltage the alternator is throwing into the battery should be around 14 v with the engine running ,is it possible you have disturbed an earth connection when you swapped the servo?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
you need to find out what voltage the alternator is throwing into the battery should be around 14 v with the engine running ,is it possible you have disturbed an earth connection when you swapped the servo?
don't think so? there was no wiring to touch really except brake light switch when i removed and replaced pin at back of pedal, but as aforementioned i replaced that anyway in case there was any damage done to it,
 

·
I refuse to grow up.
Joined
·
16,082 Posts
Put a multimeter across the battery Fully charged should read 12.6 volts (Maybe a hair less in cold temps) Start the engine the meter should now read 13+ volts but less than 15 volts.
 
1 - 4 of 4 Posts
Top