Vauxhall Owners Network Forum banner

Status
Not open for further replies.
1 - 20 of 26 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I just bought a 2003 mk4 Astra 1.6 petrol, drove fine when I bought it, but when the engine warms up the acceleration drops rapidly, when I start the car cold its fine its only when its warm. I have tried cleaning the EGR but thats not helped at all. Could it be the ECU?
 

·
Premium Member
Joined
·
1,084 Posts
welcome to vxon sounds like the MAF sensor I take it theres no eml on also what engine is it
 

·
Premium Member
Joined
·
16,228 Posts
There is no maf on the 1.6 engines. It will be z16xe, z16se or z16xep
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
How do I find out what engine is in it? Its my first car, I'm just going on what people have told me, It also sounds like a diesel
 

·
Well-known member
Joined
·
13,369 Posts
Did you get the owner's handbook with it? If you did there should be a credit card size card with details of your car on it, including the engine code. If you didn't can you take a picture of the engine and upload it?
 

·
Premium Member
Joined
·
16,228 Posts
Just got into bed but ill look it up first thing tomorrow and let you know what engine it should have in it.
 

·
Premium Member
Joined
·
16,228 Posts
98-00 used x16. 00 onwards used z16. Of course you still might get a 03 car with x16 if it was unregistered until 03 but it's unlikely.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #18
Thats the one, just poped down my local garage and they said to change the temperature sensor. He said I may aswell do it my self as it will only be about £10 for one. I shall let you all know if it works.
 

·
Premium Member
Joined
·
16,228 Posts
Don't waste your money. Get someone who knows what they are doing to look at it.
 
1 - 20 of 26 Posts
Status
Not open for further replies.
Top