Vauxhall Owners Network Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Replacing a camshaft sensor as the car wouldnt start a day after buying it !.

Cam sensor fault on diagnostics.

Is there any hints an tips on how to change this.

Seems straight forward but alot of effort!
 

·
Premium Member
Joined
·
3,339 Posts
I would be checking if the camshafts are spinning on cranking through the oil filler cap


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5
I would be checking if the camshafts are spinning on cranking through the oil filler cap


Sent from my iPhone using Tapatalk
Engine is fully turning over and cranking but it isnt firing. I've tested the output from the sensor and there isnt anything coming out. RAC CONFIRMED ... although how trustworthy I'm not sure !

It was working at 1 am then at 1030 the next morning it just wouldnt fire and then had three associated fault codes
 

·
Premium Member
Joined
·
3,339 Posts
Engine is fully turning over and cranking but it isnt firing. I've tested the output from the sensor and there isnt anything coming out. RAC CONFIRMED ... although how trustworthy I'm not sure !

It was working at 1 am then at 1030 the next morning it just wouldnt fire and then had three associated fault codes
What codes?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
10 Posts
Discussion Starter #7

Attachments

·
Premium Member
Joined
·
3,339 Posts
Being a mechanic I don’t try to understand the pedal test codes, this is purely because I use a diagnostic tool day in day out. It’s not through ignorance it is just easier and because the cluster codes don’t actually tell what module these are from.

Get a diagnostic tool on the obd and post the codes.

For now I suggest you go back to my previous post a see if the cams moves whilst cranking, because we need to rule out the possibility of a cambelt failure.
If the bottom end cranks with the starter motor but the cams don’t turn then there is the problem.

For the sake of a quick check rule this out, you may need someone to crank whilst you look through the oil filler cap.




Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
10 Posts
Discussion Starter #9 (Edited by Moderator)
Ok il get onto that today. Hopefuly not a cam belt failure! Like I said before the was driving fine all day then turned off the car. Next day - no start :(

Il check the codes today and post.

can we watts app ? Will be alot easier.

Thank you:)
 

·
Super Moderator
Joined
·
16,464 Posts
Ok il get onto that today. Hopefuly not a cam belt failure! Like I said before the was driving fine all day then turned off the car. Next day - no start :(

Il check the codes today and post.

can we watts app ? Will be alot easier.

i have removed ya phone number, ya dont know who could ring day or night

Thank you:)
 

·
Super Moderator
Joined
·
16,464 Posts
yeah but do ya wanna be woken up at 4 in the morning by some mong,

ya can always send the number through a conversation
 

·
Registered
Joined
·
10 Posts
Discussion Starter #15
All I am getting one reader now is 0100 MAF SENSOR fault.

Sensor looks ok but would this stop the cat from starting entirely?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #16
All I am getting one reader now is 0100 MAF SENSOR fault.

Sensor looks ok but would this stop the cat from starting entirely?

Took of sensor and it looks food. Cleaned it anyways and fault has gone.


All I have now is fuel filter heater coming up on pedal test but nothing on a code reader.


Checking fuel filter etc next if it does start this time.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #17
Still an absolute ***** to start if at all. Starts on a hot engine but still not smooth.

First start for the day requires many attempts of continuous cranking. Once it starts it drives perfect with no hunting or misfires etc.

It's just starting ! Battery is good, new cam and crank sensor also. No faults one code reader.

Help meeeeeee
 
1 - 17 of 17 Posts
Top