Vauxhall Owners Network Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
95 Posts
Discussion Starter #1
My air con is driving me nuts. It doesnt seem to be working at all. I have checked the gas and its present and there are no leaks. I have gone into opcom and made sure that the AC is programmed into the ECU variant config and still no luck. I am able to short the relay in the UEC and get the compressor to kick in and air con to work, but for some reason, it will not work by pressing the AC button in the car. I am able to trigger the AC relay too via opcom but only when the car is not running.

It sounds like a horrid electrical problem somewhere along the line. Is there anything in opcom that might be causing the air con not to kick in? I have changed the heater controls too but to no avail. No apparent wiring problems that I can see of
 

·
Premium Member
Joined
·
1,869 Posts
how do you defo no there is ac gas have you had it on a ac machine to check there is enough in it as if not enough it will never turn on.
 

·
Registered
Joined
·
95 Posts
Discussion Starter #3
i have a refill hose which shows that there is pressure in the system. Also in opcom it is showing there is about 800kpa in there and the cutoff is also showing "System OK". If it was low then it would show Under Pressure. The AC Information Switch doesnt change when i press the button in the car
 

·
Premium Member
Joined
·
1,869 Posts
i have a refill hose which shows that there is pressure in the system. Also in opcom it is showing there is about 800kpa in there and the cutoff is also showing "System OK". If it was low then it would show Under Pressure. The AC Information Switch doesnt change when i press the button in the car
put the refill hose in the bin go and get it checked the right way on a machine that is set up to check it for leakes and vac using the diy stuff is waste of time
 

·
Premium Member
Joined
·
1,669 Posts
If you go into OPCOM and record some live data, and also rev the engine up then upload it here in a zip file. You can then see the AC pressure and what the system has to say (whether it's okay or underpressure) I have the same problem with my Astra, this thread might help you https://www.vauxhallownersnetwork.co.uk/index.php?threads/ac-not-working-even-when-garage-regassed-it.824943/

By the way do not short the relay again until you are certain you have gas in the system, by going to a garage with the right equipment. If you have no gas in the system and you force start the compressor this can seriously damage the compressor and cost ££ :(
 

·
Registered
Joined
·
36 Posts
When I first bought my Astra H someone previously had disconnected the electric multi plug off the compressor. Obviously the a/c wouldn't work.
Just a thought. I know it sounds too pathetic but you never know !
 

·
Premium Member
Joined
·
3,589 Posts
When I first bought my Astra H someone previously had disconnected the electric multi plug off the compressor. Obviously the a/c wouldn't work.
Just a thought. I know it sounds too pathetic but you never know !
Have you checked the clutch is working on the pump as these can wear or break, open the drivers window and listen for a slight clunk / click when you press the AC button.
 
1 - 7 of 7 Posts
Top