Vauxhall Owners Network Forum banner

21 - 31 of 31 Posts

·
Registered
Joined
·
272 Posts
Discussion Starter #21
Yea, i know i have a faulty/stripped glow plug, but i have had that since i purchased the van years ago.
I think there's water in the BCM or something, i don't think a standard elec fault as i have checked everything.
Since i updated to Win10 some i can not open some sections of OPCOM (airbag for example).I have the usual drivers side footwell leak (brake servo seal) BUT i know also have passenger side soaked, never had that before.
Where the battery/BCM is is soaked, I think its crazy there is no battery cover etc , that's always wet when raining!!

The airbag light that glows dimly when van locked up it now full on, full brightness since we have had rain.
Plus i have now have the fog lamp light glowing dimly whilst driving!!

Where do i look in OPCOM for the fault? Its stated it's an electronics fault (engine or trans) and van is now running is van is now running in safe/emergency programme mode as its hard on.

Thanks
 

·
Registered
Joined
·
169 Posts
scan the ecu when the engine is running. all fault codes stored will be recorded if you are running correct software and hardware in your opcom
 

·
Registered
Joined
·
272 Posts
Discussion Starter #23
scan the ecu when the engine is running. all fault codes stored will be recorded if you are running correct software and hardware in your opcom
I can not scan ECU? I
90388
1.JPG can do everything else, i got water in the BCM unit, soaked, dried t alll out, same problem BUT my radio flicks on/off now.
90389
90390
90391
90392
90393
90394
 

·
Well-known member
Joined
·
11,959 Posts
It won't work like that, you need to manually select the year, then model, then engine.
What happens if you do that?
 

·
Registered
Joined
·
272 Posts
Discussion Starter #27
I did try that from memory 2006, Combo-C, Z or X13DT.

I'm not sure where i should be navigating to exactly tbh, i just tries to get into everywhere, when i was in the infotainment one it was connecting/disconnecting constantly?

You can see i have Combo-C, so must of manually entered it.

Also the CD30 radio was flickering on for a 2/3 seconds every couple of mins, that's not worked for weeks..lol????????


90401
 

·
Super Moderator
Joined
·
12,107 Posts
i cant help with the bcm apart from giving it a good dry out, remove it if needs be and dry every thing out properly, thats the hard part, the easy part is stopping the water getting in to the bcm, and that fella is in the pic where ya say seal has gone, by the looks of that it went a long time ago, and most likely the cause of all your problems,
 

·
Don't be afraid it's only nuts and bolts
Joined
·
656 Posts
When my corsa c was draining its battery within a few hours it turned out to be the glow plug relay staying constantly on due to the solder inside failing,£10 off eBay solved it


It’s only nuts and bolts,don’t be afraid!!
 

·
Registered
Joined
·
272 Posts
Discussion Starter #30
I wish it was that simple as a relay, this has fooked with the BCM unit itself imo, messed the software.....
 

·
Registered
Joined
·
272 Posts
Discussion Starter #31
I completely dried it withing the last few days, pulled everything/cleaned everything. My radio is back working..lol

What i can not find info on is if the fault light i have is resetable or will it self reset?

Still got the fault with airbag light/odometer ON (flashes off every 40secs for 2 secs).

I've had enough now tbh, going try in summer...lol
 
21 - 31 of 31 Posts
Top