Vauxhall Owners Network Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Apologies but my return key isn't working on my laptop. I have a 59 plate Zafira 1.6 petrol. I suddenly had a loss of power the other day. I performed a peddle test and found that I have a misfire on cylinder 3. I replaced the spark plugs. I had a spare camshaft sensor so replaced the front one first, fault still active, swapped the back one out with the front one, fault still remains. I have tested the coil pack with a standard ohmmeter, I do not have a megger. The coil pack tested ok, I understand that the coil pack may still be faulty but I am unable to test it properly. I also have a spare crankshaft sensor. I am having trouble locating it in the engine. Could it be the crankshaft sensor? If so, as I have one, where is it located? Is there anything else it could be? If so, what would the recommendations be? Thank you.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #2
UPDATE: found the crankshaft sensor, changed it, just got to put the starter motor back on and test it, fingers crossed.
 

·
Well-known member
Joined
·
14,526 Posts
Was it hiding just above the starter on the back of the engine?
 
  • Like
Reactions: andy_v

·
Well-known member
Joined
·
14,526 Posts
Do you still have the loss of power as well?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #10
Do you still have the loss of power as well?
The car starts without a problem, idle is a bit rough. Definite loss of power when accelerator is pressed, holding the revs at about 2000 the needle fluctuates without pedal movement by about 200 revs either way randomly. The code showing on the pedal test is described as misfire in cylinder 3. There are a couple of other fault codes which I shall go and get in a minute but they are related to the cooling system so I do not think they are relevant as they have been on there a while. It could be worth noting that I have noticed a loss of power on an incline if the gear is too low (despite being ok previously) at about 2000 revs, drop the gear and power resumes.
 

·
p0170
Joined
·
542 Posts
without looking at your car you may have a cylinder misfire can you film it idle then rev it coolant code can cause rough running if it’s reading incorrectly
 
1 - 13 of 13 Posts
Top