Vauxhall Owners Network Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi guys so I asked about a starting problem I had a while ago and got some great advice. However there is still an issue with the battery. I belive there is a problem with the charging circuit as when I charge the battery externally it will run for a good few weeks without any problems. The battery was bought new 2 years ago, alternator was changed about a year and a half ago and the starter motor was changed about 4 months ago assuming the alternator is not the problem what could be the issue? Any advice would be appreciated.
 

·
Worn Out Member
Joined
·
6,538 Posts
Astra H or J ?
 
  • Like
Reactions: Fred Bassett

·
Worn Out Member
Joined
·
6,538 Posts
So exactly what "issues" are you having ?
if it is an H a fully charged battery will get completely knocked out in 15-20 minutes due to current needed to work the power steering,so it looks as though the alternator is charging at least to a degree.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
So exactly what "issues" are you having ?
if it is an H a fully charged battery will get completely knocked out in 15-20 minutes due to current needed to work the power steering,so it looks as though the alternator is charging at least to a degree.
The problem is that eventually after the battery gets fully charged using an external battery charger the battery will get flat. even though like you said the alternator is doing some work, it cannot maintain the charge.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
By eventually I mean around 3 weeks. I also forgot to mention the positive side connector of the battery is getting extremely hot while the engine is running. Maybe it has something to do with it.
 

·
Premium Member
Joined
·
2,601 Posts
By eventually I mean around 3 weeks. I also forgot to mention the positive side connector of the battery is getting extremely hot while the engine is running. Maybe it has something to do with it.
That shouldn't happen, sounds like a bad/dirty connection, sort that out to start with.
 

·
Registered
Joined
·
19 Posts
I have a Zafira b and it's almost identical mechanically and electronically. Try and find if there's a parasitic drain like a bad glove box light or interior light.

I have battery issues with it going out and the battery fucks with the electronics.
See if there's any fault codes.
Usually it can be helpful to an extent.

The immobilizer (CIM ) interferes with it sometimes due to the circuit being broken and the car having a dead battery.

I'll post any info if I manage to sort my issues out as well
 
1 - 8 of 8 Posts
Top