Vauxhall Owners Network Forum banner

Status
Not open for further replies.
1 - 10 of 10 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
Hi all, I've got a 56 plate combo (No dpf) and the chain snapped a couple of months ago.. I thought the engine was knackered so I took it out and planned on replacing it. Having found it only broke 2 rockers and everything else was fine I decided to repair it. It ended up sitting in the garage for a couple of months and I have only just got round to finishing it last weekend. How ever it's cranking but won't start, I've checked the timing which is right.. I'm wondering if it has an airlock after being stood for so long?
Any help appreciated
 

·
Well-known member
Joined
·
13,336 Posts
Check the EGR valve isn't stuck open slightly.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #3
That seems to be ok.. I also have battery light on, eps light and oil light all still illuminated when I turn the ignition on and leave all the other lights to go out..
Any thoughts?
Cheers
 

·
Well-known member
Joined
·
13,336 Posts
That seems to be ok.. I also have battery light on, eps light and oil light all still illuminated when I turn the ignition on and leave all the other lights to go out..
Any thoughts?
Cheers
That is perfectly normal until the engine starts.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #6
Ok cool, i thought that it could be linked to it not starting.. I can hear the pump priming yes.. the only other thing is the glow plug light goes off almost instantly, it had this problem prior to the chain snapping. It would struggle to start from cold but it would start after a few turns.. at the minute it's just cranking..
Thanks for replys
 

·
Well-known member
Joined
·
13,336 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #10
Hi, thanks for your reply guys.. I put the battery on charge over night to make sure it was fully charged, I also checked the EGR valve again which to be honest was a little bit stiff. Made sure that was free and then tried the easy start which did the trick!
Thanks and hopefully I won't have any more issues
 
1 - 10 of 10 Posts
Status
Not open for further replies.
Top